Clip no longer shown in Auto or MTP mode...only MSC

4GB Clip recently purchased worked fine in default setting (I suspect Auto).  When I plugged it into the PC tonight is did now appear to be charging.  Switching to MSC mode seems to correct that problem but in that mode none of the music shows up in Windows Explorer.  Additionally switching back to either Auto or MTP…well the darned thing just doesn’t show up at all.

Went into device manager and noted that the device had an ! indicating a problem.  Brilliantly I deleted the device and attempted to refersh (scan for hardware changes)  this caused the pop up on the system tray to show “new MTP device” but observing the device manager list…it would add the device, and remove it at what appears to be the same rate of repitition as the screen on the clip it’s self refreshes it’s self while plugged in.

I have updated the firm ware, formatted from the clip’s menu, formatted from explorer then formatted again from the clip menu but alas…the problem remains.  If it had never worked in the default mode it would be understandable but why would it simply stop working as an MTP device and why wouldn’t reformatting correct the problem?

Any help in this would be greatly appreciated.


Do you have Windows Media PLayer 11 installed? If not do that and see if it helps.

Yes I have MP11

WinXP Pro SP2

Same as I had when it worked in Auto mode…no recent changeds to hardware or software.