clip is not playing songs anymore

I’ve been using clip for the past 8 months and quite regularly for the past month. Today something strange happened. When I click play, the icon on the screen changes (to “||” ), but the song does not play. The time is not running…I charged it to 100%, resetted, but there is no difference. When I click play, nothing happens (except for the play/pause icon). I tried different songs, also the ones I listened to this morning. No luck.

I also noticed that it now boots a bit longer and at the end of this process the screen goes slightly darker for 1-2 seconds. I’m not sure if it worked like this before, didn’t pay attention. Does anybody have a clue what can be wrong? I really don’t want to have this thing replaced again…Thanks

BTW. All other options seem to be working just fine.

EDIT: OK, as a last resort I decided to do a full device format and to reset settings. Seems that it helped. Fortunately, I have all the music on my hdd.

Message Edited by bungl on 09-19-2009 01:34 PM

Message Edited by bungl on 09-19-2009 01:34 PM