Can't Play Movie on iPad 1

Downloaded movie to flash drive in .mp4 format (approximately 2 Gb file) and it will not play on iPad.  Only image on the screen is the play triangle with a circle with line through it.  Are there specific settings required to play the movie?

make sure you have updated to the latest Firmware and app. You can also download an app called Airstash+. It works with the WFD as well and may play the file. 

Updating firmware enabled me to play the movie but it is highly pixellated and unwatchable.  Tried formatting the movie into an iPad-friendly format and still not joy.  In fact, the app itself closes.  Tried Airstash+ and same result.  Any other suggestions?  Thanks in advance!

Have you tried to play this video on your mac or computer, it is normal? If this video can play well on your computer, what format have your formatting to and how? Maybe you can try this to transcode it.

set output format

The mp4 has to follow an exact specifications. Below is link that will help you.

[url]http://www.bigasoft.com/articles/how-to-play-mp4-on-ipad.html[/url]

Hello, you need to know that ipad supports mov files playback, you can convert mp4 to mov. I found this freeware Adoreshare free mp4 to mov converter, I am not sure if it can help you, you can try. After all, it is free