Can't install Windows 10 on Sandisk Plus SSD


I’ve been trying to do a clean install of Windows 10 for weeks (since before Christmas) on my new Sandisk Plus SSD 120 Gb.

My motherboard is a Gigabyte GA-P55A-UD3P rev. 1 (firmware F14), and only the SSD and an optical drive are connected (I have disconnected my HDD temporarily). Control mode is set to AHCI. 

Symptom: When I boot to the windows 10 dvd, the windows logo shows, then that circle of circles start spinning, then the computer reboots (in loop).

I have tried both GSATA (Marvell 6Gb/s) and SATA (P55 Intel 3 Gb/s) ports with identical results.

Also I have tried other windows dvd, tried to install via flash drive, tried other optical drive, tried windows 8.1 and even tried windows 7. Also tried changing the control mode to IDE! 

Did also a bunch of tests trying to disable some settings on the Bios (audio, lan, etc) but no joy.

But all tests resulted on the same reboot loop.

I have checked that the SSD is set to ‘unallocated space’ using a bootable partition tool (just to be sure that my tests did not screwed up the partitions). 

Anyone here had a similar experience? Any ideas about what to do?

1 Like