Can't download firmware

Anybody else having this issue?  The Sansa Updater doesn’t seem to want to download the 5.5 MB file for the most recent firmware (1.01.05).  It quickly gets up to about 55% and then says “failed to download the selected file”.  I retried dozens of times over a two night period with the same result.  Anybody know anything they can pass along?  I never have problems downloading files or apps.  What’s going on?!!?

Follow the instructions at the link below… worked for me!

If nosync’s answer doesn’t help…  have you tried using another computer, rebooting yours, and resetting your router (if applicable?)  I haven’t had any problems with the updater recently.

Nosync, that was the charm.  Thank you!!  Updated the firmware tonight from that link.  Went to RadioShack and bought a 2GB Sansa micro card on sale and feelin’ groovy.  Listenin’ to the tunes I syncd tonight with WMP and lovin’ my options to beef it up with much more capacity.

Thanks again!

Message Edited by djbbjd on 01-07-2008 09:58 PM

Message Edited by djbbjd on 01-07-2008 10:00 PM


Don’t know how that would help as everything else goes fine.  I have downloaded demos and download different files daily (e.g. Podcasts).  Don’t know why the updater software didn’t like me or my PC.  The other way worked like a charm though.  Thanks for the post.  Appreciate the effort.

Message Edited by djbbjd on 01-07-2008 09:57 PM

Message Edited by djbbjd on 01-07-2008 10:00 PM

nosync, I followed all your instructions and it didn’t work for me. When I pressed the (-) while plugging into computer, found new hardware came up wanting a cd to be inserted. Thanks for your help.