Can't connect and freezing all the time...

I purchased my Sansa e280 in December and I have been a happy camper since then, however, I just tried to charge it 2 days ago and the thing froze, I could disconnect it properly so I pulled the cord, after that, I lost all of my music, ok, no problem i’ll just sync it again, Once I connected it again, it said device not recognized…then it said the USB device has malfunctioned and Windows does not recognize the device…also a message that says, installation of new hardware has failed, your device may not be working properly. Now everytime I hook up the device to see if I fixed it, It freezes on me and I cannot do anything…Now I also had a full charge since from this morning, but I tried turning it on to play with it again and it said charge too low, device shutting down…so not only will it not charge and I’ve lost my music but it says that it isn’t recognized and it freezes left and right…can someone help me out…has it lived it life already in only 7 months. :frowning:

Thanks, S

I’m having this same problem.  I have a SanDisk express and it is dead now!  Sometimes it would lock up when I turned it on but, when i connected to my computer it would unlock.  I don’t know whats wrong now.  I tried to charge it and it wont come on at all and now when I connect it to my computer it says “USB DEVICE NOT RECOGNIZED”.  Did you get any help with your problem?

You should repost in the Sansa Express forum.  You are in the forum for a player that Sandisk made with the name “Sansa Connect.”