Cannot Update

Hello everyone -

Our family has two different Sansas.  One is a E250 and the other is an E260.  They both seem to be having the same problem…I cannot get the firmware update to install.  It downloads just fine but it says “Failed to download the required firmware files.” and in smaller letters “Firmware update cannot continue at this time.  Please try again later.” (this is version 1.02.18 and I’m using my e250 as the example, but both players exhibit the same issue).  Any ideas?

Thanks bunches! 

they both have 1.02.18a on the players? This is the latest firmware and your players dont need to be updated if this is the case.

First - both players are regular E200 series right? No R after that or Rhapsody when it starts up or on the back of the player, right?

Second - how are you trying to update? Is it using the Sansa Firmware Updater or a program like Rhapsody or Napster?

I’m also assuming you’re trying to update TO the 1.02.18 firmware, correct?

Sorry for all the questions! :smiley:

No “R” after it and there is no Rhapsody when it starts up…and I have been using the Sansa updater (I didn’t even know you could do it another way…so…interesting).  And yes, I am trying to update TO the 1.02.18 firmware (it’s what automatically downloads at least…).

Hope this helps some…


you can try unisntalling the firmware updater and reinstalling it.

Worst case scenario you can call sandisk and ask them to email you the firmware update since the sansa firmware updater isnt doing its job right. Easiest would be to try another computer i guess, if thats even an option though. :slight_smile:

Enigma -

I have previously tried to update both on my laptop, but experienced the same issue…

So my last option is to call?

Thanks again!


it appears that way. Just call and state whats going on, let them know you want to recieve the .mi4 to update your firmware to .18a since the firmware update is not working and you tried it on different computers. They will put you on a list to have it sent out.

Just so your aware, most end-users dont really notice a difference. For the most part the player will act as it normally has, with minimal changes. I dont know all of those changes are; as sandisk doesnt release firmware notes.

Hi, I also have the same problem.

I have an e250 and am using WinXP.
my firmware is 1.02.15.

EVERY time I try to use my fresh download of the firmware updater I get the same error as above.
THe update fully downloads and then quickly tells me it cannot update.

I tried BOTH my laptops. I sent an email last night and haven’t gotten a response yet.

The “R” series has a manual firmware update, isn’t there a manual application I can do?

                Thanks in advance

there is no manual one for the regular e200’s. You should get the file soon, worst case scenario… give sandisk a call and request it.