Cannot enter microsd through MSC mode

Ok, I did the MSC think so I can reformat the internal memory to FAT32. Anyways, it’s all good, until I put in my 8gb microsdhc [which, btw WORKED (note the past tense)] but I can’t open it up. It’s odd because through MTP (I have WMP11 btw) I can open it, but cannot reformat either of the two.

BTW, I’m trying to fix a problem where my microsdhc stops at “refresh database.” I have the latest firmware and I know it works (as it did before). If I just let it be, the player eventually turns off. 

Should I just go out and buy a card reader that supports microsdhc or is there a solution to my problem?

yea you can get a cheap microsdhc reader from dealextreme (google it). I wouldnt trust the player adding/removing songs because it transfers alot slower then USB 2.0 so its very questionable but it is also possible you have too many songs also

too many songs?

Yeah, I forgot to clarify; in MTP mode, I was able to reformat the card and in IE. But in MSC mode, no go =[

I don’t know what I should do =’

EDIT: I tried to fix it, but it got worse. Now, w/e I connect my SE to my computer, a bubble constantly pops up saying MTP device. Also, I can’t get into the SE device; I can’t get pass the updating database. Also, the battery icon is now on my left hand side rather than my right. I think I tried to get into recovery mode to fix it, but things just got worse.

I don’t know how this happened. I’m probably going to return the thing if nothing can be fixed.

Message Edited by soyandrice on 11-12-2008 11:43 PM