Cannot Delete Factory-installed Podcast

I just bought a Clip Sport from Best Buy brand new.  I updated the firmware, then went about deleting all of the music and podcast files that were preloaded on it.  In Podcasts I encountered a folder and a file that I cannot delete: the folder is “…  !. 0” and the file is “EARTHS~1.P3.”

When I try to delete the folder Windows Explorer asks if I really want to delete it, I say yes, then nothing happens.  When I try to delete the file I get the “file name too long or invalid” error.  I cannot rename it without getting the same error and I cannot delete it.  I tried to delete it using the firmware (by selecting the file on the Clip, hitting the “Options” button and deleting the track), but it can’t play the file because “File format not supported!”

I have 2 questions:

  1. How do I get rid of these things?

  2. Why would SanDisk instal unsupported, undeletable stuff on their products?

change in setting the usb mode to mtp and on ur PC delete it.

If you format the player using the player’s menu, it will get rid of all the songs and podcasts stored on the player.

Then you can reconnect the player, and reload your music.

Soon after opening the package, I format a Sandisk player using the player menu. Settings, system settings, format. This gets rid of all the sample music and podcasts on the player. 

“change in setting the usb mode to mtp and on ur PC delete it.”

The Clip Sport does not have an MTP mode.

ohh ur right :smileyvery-happy:

my bad. got it confuesed with my zip clip.

anyways i remember deleting from my compter all the content that came with my sport clip.

That did it.  Thanks a lot.  I bricked my last one, so this kind of stuff was really stressing me out.

I had the same problem, but in the Music directory. A corrupt file system. See what is in the .. !. 0" directory. In my case it was a " $' directory whose content was ... the " $" directory. Impssible. Not on a corrupted file sytem. The bad file I had was "[garbled].mt3!' instead of HoldOn.mp3. It recognizes file types by extension. The extension was garbled so it would not even try to play the file. I copied it to my computer, changed the filename to "a.mp3" and could play it. Use the players Settings System Settings Format Internal Memory command. It does more than format the system. The player I got was formatted as a "super-floppy". The format command partitioned it to create a separate user partitiion and reinstalled some libraries from firmware (apparently that fixed a corrupt M3U library - for then my playlists worked). A corrupt file system on a super-floppy (no partition table, like a floppy, just a big single disk) formatted player. Tech support tried to get me to format it using Windows. Bad idea. After the format using the player's own format command it is partitioned so that only the user data is on the accessible partitiion. Much safer.