"File format not supported" randomly appears

I bought this player to replace my aging Clip+, which has not had any problems with the MP3s I loaded onto the SD card (either stock firmware or RockBox). I used a new SD card in my new Sport and copied all the music from my Clip+ to my Sport. Now, randomly, I’ll sometimes have the player randomly stop playing music, display “File format not supported”, and I have to hard-reset the player to get it to play again.

The thing is, I can’t replicate the problem at all. I did a search in Windows Explorer for NOT name: *.mp3 and it came up with nothing. I then skipped through my entire library (eating up the better part of an hour…) from start to finish and not a single song threw the error.


Is anyone else experiencing this problem?

1 Like

What is the file format of the tracks (and the source) that don’t play?

As noted in to OP, every file on the card is mp3 format.

Also as noted in the OP, I can’t isolate the problem because skipping through the entire library results in every file being played without issue. There are no logs generated on the player, otherwise I could perhaps discover a commonality between the random drops.

The files are from all over. Some are CD rips, others are downloads.

It shows between each song on mine, when I want to manually advance it slows me down.  Have tried everything. My system is updated, checked, rechecked. Windows media player is correct.  I need help!!!

Did you try reformatting the player under its System settings (save your files to your computer first), and/or manually reapplying the firmware (see the firmware thread above)?


Got the same issue now - randomly ‘File format not supported’ - mainly with ogg though.

But I had no issue with these files on the Clip +.

Moreover, this problem sometimes comes whil trying to resume a ‘audiobook’.

I am running v1.17…


1 Like

I have had this problem, but it has been very specific to podcasts from NPR. Other podcasts and audio books have not been a problem. Have not downloaded any music.

I had some success when I used Windows Media Player (WMP) to ‘sync’ the podcast, but that stopped working last week.

I’ve only had this player for a few weeks, also used a Clip+ which  also had problems with these files.

I’ve been working with Tech Support for the past 2 days and hope they will resolve the problem.

Or just a hunch, this could be a lose connection on the SD card.

I also have been having this problem with NPR podcasts.  I have had 2 other Sandisk players before the Sport and have never had a probem like this.

The really odd thing is that the podcasts start to play and then after playing fine for about 10 seconds it stops and says “file format not supported.”  It does not happen with all files nor even all files of a given podcast.

It is very disappointing to upgrade to a new player and have it be less functional.  

Has anybody from Sandisk helped anyone with this?

Same with me on NPR podcasts - it happens right after the ‘this podcast is supported by’ message.  NPR podcasts without that message play fine on my clip sport.

Hey eswcpa,

Did you have any luck getting this sloved?  I have been “working” with tech support also, but it is not possible for me to send them the files I am having problems with becaue thier email only accepts attachemnts that are 9MB or less.  They are supposed to call me to discuss this but I can’t imagine what they will tell me over he phone that is different than what they have told me via email (they gave me directions to remformat the player - it didn’t help).


if the file is too big to send you could always use dropbox or something like that and send them a link to the file. 

Yeah, I ended up using Dropdox and when they tried to play the files the same problem occured:


“I appreciate your continued response. I have tried the files and could replicate the issue. It seems to be the issue with the bit rate of the files. The bit rate of the files you sent was 56kbps which is generally not the case for normal mp3/WMA files. I have tried converting them using Any Audio Converter to 128kbps bit rate and it worked. As a work around you can download the same converted and try to convert them to get them to work. We have reported this issue already to our development team for further review.”

I am not convinced becuase the problematic podcasts play until the sponsorship announcement is finished (between 15 and 20 seconds) and then give the error.  Also, some of the podcasts from the same show with the same bit rate play just fine.  At the very least things have been frwarded to te development team and maybe we will see a firmware update to fix this.

What puzzles me is how all of my earlier Sansa players can still play these but the newset one cannot!  Surely the developers can compare the old and new codecs and see where the issue lies.

Did you try converting the files to 128kbps and see if they play normally for you? it sounds to me like they tested that out and it worked. 

they have said it was reported to the development team so it sounds like a bug which would probably be fixed in a future FW update. 

I get this problem too.   All of my MP3’s are CD rips.   I have a theory that it’s my 16GB microSDHC card.  It’s a class 10 and you’re supposed to use a class 4.   Will repost soon once I receive my new class 4 card and try it out.

Yesterday I ejected my microSDHC and loaded all of the MP3’s I wanted in the main Music folder.   I also did a CHKDSK /r /x from Windows (which reported no problems).    After that, everything was good.    BTW, before I was not only getting “file format not supported”, I was also getting “file not found”.    I’m running the latest firmware.    All of my files are MP3’s ripped from CD’s with Windows 7 at the highest bitrate it offered.

Vymeniť MicroSDHC kartu. Odporúčam MicroSDHC Kingston 16GB Class 4.

im using Transcend 64GB class 10 SDXC and having occasional freezes. but all files work.

im using mostly FLACs and mp3 320 CBRs.

@ninjafrog84 wrote:

im using Transcend 64GB class 10 SDXC and having occasional freezes. but all files work.

im using mostly FLACs and mp3 320 CBRs.

So your files are heavy, which may help not to exceed the 2000-file limit, right? Or do you operate in folder mode?

yes - mainly heavy files. but just to make it clear , its not full.

no - im using tag browsing …not folder