mp3 files show as "File Format not supported"

I am puzzled. I have 5 of the Sandisk Clip Sport (8GB). I use them with a 64 GB MicroSD card, no problem.

Now I face an unexplainable (for me at least) issue. I have two file directories with lectures. Both look absolutely identical to me when I check the file type (with mp3tag) - but one plays without problem and one does not play at all and gives the message “File Format not supported”

Files in both are: MPEG 1 Layer III, Tag ID3v2.3, 128 kBps, mp3 Format

I put both in the 8 GB Storage area, still the same. One directory plays and the other says “File Format not supported”.

Would appreciate any idea how to solve this issue. Thanks.

Solved it now. I downloaded MP3Repairtool.exe and ran it on the “non-playing directory”.

Now, the files play normally in the player - even so I don’t know why…

Thanks, maybe some input for others with a similar problem.

1 Like

Thanks for the info., tip and tool.  I once had a similar situation and opening and re-saving the files thru MP3Tag fixed matters.   :slight_smile:

1 Like

Thank you. Your post was helpful. I encountered the same problem with a homemade MP3 mix file and couldn’t transfer it to my Clip Jam without your advice. Listening to it now. Awesome. Thanks so much!