Browsing Problem

I have the 8GB model and after i dragged and dropped some albums in tried to play them.

All albums were tagged ID3v1 &v2 with Tag&Rename software.

10 album from 10 different artists. But appeared only 5 artists via tag browsing, rest appeared as “unknown” with all their songs in one “unknown” album…

So i browse my player only via “folders” selection, but i always prefered tag browsing…

If tags are ok why does it do that ?

Anyone have similar problem ? Any solutions ?

Message Edited by psytransas on 04-15-2009 10:43 PM

It’s likely some of your tags are not in ISO format.  See this thread.  I had similar issues, and once I set MP3tag to ouptut into ISO tages, everything went fine.

Hope this helps.

@psytransas wrote:

I have the 8GB model and after i drugged and dropped some albums in tried to play them.


Probably cause you drugged them.

 Sorry I couldn’t help myself.  But seriously, I’ve had this problem before too (and sometimes things would show up with chinese characters).  As p_opus said, it’s probably because some are not in ISO format.  I use Winamp to do edit my tags, and for some reason a few of them would do that.  I’d just go back and erase the tags, write in the information again and reload them on my Fuze.  After doing that they’d show up fine.  So I guess some of my songs were not tagged correctly, so I just had to retag them. 

v1 is useless. Sansa doesn’t read them.

There are various kinds of v2. The Sansa prefers v2.3, though I have found it will also read 2.2. 

Read this ID3 tag FAQ  for information on how to make tags the Sansa loves.  Basically you get the free program mp3tag, change its settings once, and tag each album before you give it the drugs. No more hassles. 

Well guys, beyond the jokes thanks a lot for your help…

Perhaps they should put these informations on manual to make our life easier…:stuck_out_tongue: