Brand new Ultra 64GB doesn't work

Hi guys,

I had to go abroad quite urgently in late November, I wanted to bring my camera along and since I couldn’t bring my laptop I went and bought this memory card from Curry’s on the day I was to go away as I was very short on time.

Obviously this is a huge brand so I had no problem paying a bit extra for it. Sadly, upon arriving at my destination I saw that my camera wouldn’t recognise it, asking me to format it first. I wasn’t able to do so using my camera itself so I borrowed someone’s laptop instead and tried formatting it using Windows usual formatting thing - still no luck.

I thought that since there was no internet there maybe their drivers were not updated so I waited until I got back to England to try on my Laptop but still no luck. It can’t be a fake as I bought it from a very reputable company, there are no signs of damage on it at all, it looks great.

The computers can see it but simply can’t format it. I have even tried the program from SDCard. org and that doesn’t work either, it sees it but upon starting the format it says ‘Not Responding’… Other times it keeps asking me to remove the ‘Lock’ but I have checked and it’s definitely not locked!

Can anybody help me please? :smiley:

Your help would be greatly appreciated!

I need some help urgently guys!:frowning:

Sorry to say, I doubt anyone here has any solution for you other than recommending you contact SanDisk Tech Support/Customer Service, Here’s the UK contact info:

UK (English)

Local UK time
M-F | 8a.m - 7p.m



(44) 203-3183-965

Good luck!

Okay thanks! What kind of outcome can I expect though? I paid nearly £40 for this and never ever got the chance to even use it. Since I bought it about 2 months ago I doubt the original retailer would even consider giving me a replacement/ refund :frowning:

If deemed defective or inoperative by Tech Support, they (SanDisk) will replace it under warranty.