Blue Ring doesn't light up at starting


I bought two days ago a FUZE 4GB and everything seemed OK.

Yesterday, when I switched on the player, the blue ring hadn’t lit up before the screen. It just lights up when I touch the knob for the first command.

Is there anyone who has an idea about it? Could it be the start of a worse malfunction?

Thanks in advance.

P.S.: sorry for my rough English.

Try resetting it – holding the power button up for 20-30 seconds. 

It was the first thing I tried (the second was firmware’s upgrading). No result.

By the way, is there any sign that resetting has been done (Fuze remains simlpy shut while sliding switch off control for 30 seconds or more)?

One of the mods or the admin had mentioned that with sensitive earphones, a faint click sound may be heard when the fuze has reset.

I had to reset my fuze twice because a video had caused a black screen and then it froze on the logo when I tried to turn it back on after the first reset.  Both times when I held the power switch up to reset it, I heard a click.

Thanks for clarification about reset.:wink:

To whom may concern: Sandisk wrote me that what I mentioned is not a real problem but it’s a bug related to the firmware. I’m a bit perplexed…