Battery Problems with the Fuze

I’m having battery problems with our Fuze.   When it’s unplugged the battery is on red.  As soon as it’s plugged in, it charges for a few seconds then indicates the battery is full.  As soon as it’s unplugged, the battery indicator goes back to empty.  I’ve tried it on several different USB ports on two different computers using two different cords with no success.

It has the latest December firmware update.  Any ideas?

We already had one Fuze die within 3 months.  This was the RMA replacement and we’ve only had it a month.  I’m really beginning to think this is a dud product.

You charged it first, fully, correct?

 Are these new enough computers?  My laptop is so old it really doesn’t show much and doesn’t charge it anymore (did when I first got it).

Have you tried another way to charge it, if you have the accessories (like car or wall plug)?  If you have one for another USB plug in, the fuze one will work.  I just bought a generic plug and car chrager kit and it works for mine.

I havent had any problems with charging it myself, thankfully, but I saw somewhere that your facefront USB port doesnt charge as well as the back control panel USB port does so that may help you.

Try changing the USB mode on the Fuze and see if that gives you any results.