Battery discharging and won't recharge??

After purchasing an 8GB Sansa View and giving up on it inside of a week after experiencing every problem you can imagine and then some, I returned it and replaced it with an 8GB Fuze.  I’ve had for about a week and it performed flawlessly until this morning.  The battery was down about halfway, so I plugged it into my PC in order to get it fully charged.  However instead of charging, the exact opposite happened - the battery drained completely and now it won’t charge up again.  I’m totally confused with this - can anyone suggest something I may have done wrong??


will the device charge on other usb ports or other computers? if you have a self powered usb hub try connecting to that to see if it will charge.

I’ve noticed that sometimes after transfering to/from the Fuze, it will drop out of charging mode, while remaining on…

I’ve tried it on 2 separate PCs, including one I’ve charged it on several times in the past and never had any trouble with.  So I don’t think the machine or the USB port is the problem.

The Fuze likes a tasty 5 volts and a 200 ma flow peak.  This capability is provided by the new USB 2.0 standard.  Connect your Fuze in MTP mode (Settings > USB Mode > MTP).  Go to My Computer > Sansa Fuze > right-click > open Properties.  The power management screen should open, showing the battery status.

If the Fuze shows up in My Computer, it is communicating.  The new generation sansas have their charging managed by the device’s processor; if the device isn’t communicating properly, they can lose track of the charging function.  Check if your battery icon on the device shows that it’s indeed charging.

Bob  :smileyvery-happy:

I have the same problem as Robzombie. When connected to my PC, the battery will not charge. The PC sees the Fuze fine. The problem may be that the battery status in My Computer-> … -> Properties  reads 100%,  even when it is clearly not 100% charged.

I tried charging off of a wall unit and the battery does seem to recharge fine that way.  

be it’s bcuz u have to many items in the san fuze?? i mean its jus an idea…i dont even have it or nethign but it could b dat…maybe too much storage?? or it could b the computer?? is it slow bcuz that could mean it’s affected by sumthing…

I had a similar experience with battery not recharging on my Sansa Fuze. I tried multiple computers, multiple cables, even tried attaching it to a Wii and a wallwart usb power adapter. Also tried with the lock on and | button pressed as I attached. NO GO on any of them. The device wasn’t even being recognized on any computer. Then in a desperation move I tried placing a microSD card in the player. I tried a attaching with it in and it still wasn’t recognized. I then tried again with the microSD card removed, lock on and | pressed and the Fuze was recognized! Best guess is that the USB firmware was stuck and by inserting the microSD card, the driver was forced to recognize the additional memory breaking it out of the loop.

Cycling a microSD card forces the Sansa to do a database refresh.  Another handy trick, if the Fuze won’t behave, is to hold the power switch in the ON position for at least 20 seconds, then try powering up again.  This will reset the device.

Bob  :smileyvery-happy: