Avoid SanDisk Secure Access!

Today I received a SanDisk 32GB USB-Stick from a business partner. The stick baiscally should contain about 24 GB of Database backup data. Unfortunately (for me!) the data was not saved in a readable form for my DB-Restore but in a SanDisk vault, encrypted.

So what’s to do? Right. Start RunSanDiskSecureAccess_Win.exe, a program located on the stick, and enter the password to access the data. That’s however, how I imagine (I’m software engineer for 30 years) it should work.

But that’s where the trouble starts:

  1. Starting RunSanDiskSecureAccess_Win.exe shows an initial startup screen which looks like this ( http://img41.imageshack.us/img41/1366/snagprogram0430.png ) for full 14 Minutes until the program actually starts and allows to enter a password!!!

(Question on the side to the SanDisk People: Why does it take 14 Minutes? An why is no information provided telling the user that it might take “some” time to start up the application? From my professional point of view I know that some kind of counter/screen/progress bar is necessary to inform users whenever an operation needs more than 20 seconds to complete. Otherwise the user might think the program has crashed!)

  1. Once I have entered the password, I finally received a picture like this http://img841.imageshack.us/img841/4548/snagprogram0431.png after another 19 Minutes of waiting time.

  2. Now I marked all files on the drive and draged-and-dropped them to my harddrive. No idea whether it will be working or not. But after the experience so far, I guess I should give the application some hours to complete a 24 GB file transfer :frowning:

Conclusion: I recommend to put data on a clean stick just as simple files and definitely avoid using the vault-secure access software as this is too time consuming and confusing. I think that most users (at least me!) want to access data on a memory stick within reasonable time (and that’s seconds to minutes and not minutes to hours).

My recommendation to SanDisk Company therefore is: Please inform your users within the secureAccess Software, what’s currently going on, what your software is doing what progress in processing is made every minute and how long the process might last to complete.

In short: The process you nicely describe in your video at http://www.sandisk.ca/products/usb-flash-drives is a process which needs at least 30-60 Minutes in real-live! Inform your customers about it!!!

Thanks so much for this warning.  I only wanted to be able to lock access to my files, not encrypt them.  So I quickly uninstalle the software and will just go along as usual.  It would have been awful to have had to deal with this, not having your expertise. So again, thanks for saving me from this trap.

I wonder what does ScanDisk Secure Access do with 29MB (29MB !) of code !

I have other USB memory sticks with comparable data protection software that is only 1.4MB

The obvious result is that “Secure Access” takes ages to load and, it very clumsy to use and seems to be designed mainly to advertize other services offered by Sandisk.

Until Sandisk comes up with a simpler alternative, better reformat the USB drive and forget about “Secure Access”

Glad to see I’m not the only one that thinks this software is a joke.

I recently had the opportunity to use Verbatim’s software. Now that software was worth the price of admission alone! It worked smooth and flawlessly. None of this messing around with insecure, overly complex passwords, HORRIBLY designed software, and, to add insult to injury, an inability to change the password.

PS I find it amusing that the SanDisk site is willing to accept alpha-only passwords but their terrible piece of software forces you to use insecure–yes, insecure–alpha-numeric passwords. Yes, I say mixed alpha-numeric passwords are less secure because the complexity of the alpha-numeric passwords force users to either write them down (defeating the whole point of a password) or to make these mixed passwords easier to remember which means that you end up using simpler, more predictable passwords (I’ve NEVER had anyone crack my alpha-only passwords but I did once have an alpha numeric one cracked).

Reminder to self: NEVER buy a SanDisk memory stick again.

This is simply not the case. Alpha numeric password are much more secure than letter only passwords. This is a simple fact due to the number of combinations that can be used. If your preference is to use less secure passwords then that is on you. Letter only passwords are easily hacked by using brute force attacks. Just because you do not like the extra security requirements does not in any way make it less secure. 

http://www.wikihow.com/Choose-a-Secure-Password

I just picked up a SanDisk 16G drive and wanted to do some research on the SecureAccess program that came with it, to see if it was really worth using. Thus, I found your article/post.

One thing to remember, as a general rule of thumb with any kind of hardware you buy, is that the free software that comes with it will 99% of the time, be very low-quality. Unless the hardware can *only* be used in conjunction with the provided software, there will always be a better program out there somewhere that does the same thing, that works better. In essense, the software was only created to help sell the hardware.

I noticed you didn’t raise any concerns about the actual encryption quality (how easily can it be crack/hacked? which is what I came here for), so I’ll skip that. The lack of a progress bar: you’re right, it wouldn’t have taken much extra time for the programmers to include that, and would have been extremely helpful! On my first run of the program, that screen popped up instantly, because the drive was empty - this was something you didn’t have the chance to experience because you received it with XX gigs of files on it. Again, I attribute the lack of a progress bar to the issue I described above.

The reason it took 14 minutes to load (an unusual amount of time) is because the program was processing (in some way or another), all XX gigs of data before the program would load. Probably not just “reading” the data, because it would not have taken 14 minutes even if the drive was full, unless you had an old computer with a USB 1.0 port. If this 14-minute pause happened after typing the password, the program was probably decrypting the “headers” of each file…a task that still should not have taken very long.

Of course, this program is not one-of-a-kind, and if you need a program that does what this does, you can always search Google for “USB flash drive encryption” or similar. I’m sure there are many companies/private developers whose main interest was in creating a decent flash drive encryption program, and not in selling flash drives, and therefore, have put a lot more time/work/effort/energy into developing a decent encryption utility.

@hideme - did you buy the flash drive solely for the software? I’m an adamant believer that you shouldn’t judge the hardware for the free software that comes with it, especially when the software is optional. In most cases, flash drives do not come with any software anyway, so it’s like saying the flash drive would have been a better piece of hardware had it not come with any software at all. Remember, the software can be deleted anyway, and replaced with third-party software.

I do agree that the program that comes with it is sub-par to anything else available on the web. It was only created and added to help them to sell the drive. Makes for better package advertising. :slight_smile: Though the program itself is not something I would ever use, based mostly on the original poster’s review, I would still continue to buy SanDisk products based on the quality of the hardware.

This is not the first piece of quality hardware I’ve bought with low-quality bundled software, and I’m sure it won’t be the last.

I just purchased 2 x 8GB SanDisk USB drives mainly because of the “encryption” software that is included with it, I must say that I am truly disappointed with it and will definitely be removing it from the drive. 

I will continue to purchase SanDisk products, but the company may want to review who they partner with as issues like this will tarnish their reputation.

Bought two SanDisk 8G Cruzer Blade thumb drives because of the encryption. Setup both with the same password. Opened and closed the two a number of times putting data on; reading it off; putting it back on and now neither will allow me to login. Seems to have forgotten.

Also, if one wants to have something secured, why do you have to move it from a secure place to your PC/laptop; edit it; move it back; then delete it from the PC/laptop (realizing that it isn’t REALLY deleted?)

I bought a few of the USB Cruzers in the past and now much to my frustration, I find that they totally revamped their flash drives! You no longer can just plug it in and open the files, no way, that would be too conveinient. Now you have to download some stupid software and if you’re not careful, you’ll download crap like MacAfee AntiVirus plus and other crap that has nothing to do with using the flash drive which is now “Powered by YuuWaa” …whatever. 

Flash drives are known for their ease of use and this piece of crap is anything but easy. There’s like 4 folders in the drive so here I am clicking and opening up these folders to find which one you can put your files in. You have to create a friggin password and if you forget it, you’re screwed. Finally I figure out it’s 'My Vault" and when I go to look at  photos that I’ve put in there, I no longer can just toggle through the photos using arrow keys like before…Now each time I click on a photo in My vaults, a stupid  message comes up telling me it will be a ‘read only file’ …this never happened on their old flash drives. Their so called chat support through chat was a joke because after I told them all this, they just figured I was a jerk and was ignored in chat.

I will NEVER  purchase anything by SanDisk ever again. Back it goes to Best Buy tomorrow!!!

@because wrote:

Now you have to download some stupid software

No you don’t.

@because wrote:

There’s like 4 folders in the drive so here I am clicking and opening up these folders to find which one you can put your files in.

 

Just delete them and it will be like any other flash drive, even the old ones.

 


@because wrote:

Back it goes to Best Buy tomorrow!!!


 

I think you’re making a whole lot more out of this than what there really is, but whatever floats your boat.

I have a 16 gig flashdrive using secure access.  I’ve been using it successfully for a couple years.  I recently got a virus and had to employ Geeksonline to get rid of it.  I also had added a file to my flashdrive and there is only 111mb left on it.  Well, I now do not get my secure access and login when I plug in my flashdrive.  It used to come up within five minutes.  I waited 15 and it still didn’t show.  I deleted all the registry files and plugged in my flashdrive again.  Same result.  Is my flashdrive too full so the software cannot now work?  Can I copy my flashdrive to my hardrive and see if it works from there?  The flashdrive is okay because it boots up fine.

Bud

I stored some files in the Secure Access vault after purchasing a new 64gb SanDisk flash drive.  Today I popped in the flash drive to put them on my PC hard drive.  After putting in the flash drive the Secure Access vault recognized it and prompted me for my password.  I successfully logged in and dragged a few videos onto my desktop.  Now the encryption has corrupted all files.  .JPG file were the only ones to survive.  I cannot view the files from the vault, public folder on the the flash drive, or once I drag them to desktop.  I have tried 4 media players and they all say the files are corrupted.  I even reinstalled Windows media player, checked all usb drivers etc. etc. etc… Tried viewing the files on two other computers with the same results.  Thank you SanDisk and YuuWaa for trashing a years worth of pics and videos from my smart phone.  AVOID SECURE ACCESS!!

Hi !

 Avoid SanDisk Secure Access!

I was using sandisk few month.

But last week in a new cybercafé with a very good network I discovered something very strange:

1-   a LL THE INTERNET BROWSERS WERE CLOSED IN MY COMPUTER.

2-      I runned  “SanDisk Secure Access” and I discovered that this software tryed to do go through the web!!!

Why that?

It’s ridiculous:

This is a sotware designed to watch secretly your file NOT TO CONNECT THE WEB EACH TIME YOU OPEN IT!!!

I don’t create softaware but this is AGAINST LOGIC!

MEANS FOR ME :   everything that you will try to keep secret why sandisk is released to an information agency!!! SIMPLE AS THAT!

ADIOS SANDISK !

Having read the commentary, I have to admit I’m a little puzzled at some.  I’ve owned any number of SanDisk thumb drives (TB) in the past, understood their pros and cons, and never had a problem with them.  I just purchased the SanDisk Secure Access TB. I like the ‘Vault’ program.  I have a HP Pavillion Phoenix H9-1130 CPU, Win 7 OS, AMD FX 8120 8-Core Processor (eight 3.1GHZ processors) and plenty of RAM.  I understand the complete I/O process and have no expectation that a TD will function as quickly as my CPU.  It’s somewhat difficult for me to think that other users have a different expectation. Requires 8 or 9 minutes to load a big file?  So what!  Minimize the screen and do something else for awhile. I can assure every Reader out there that no one will ever get into my SanDisk thumb drive, given the mixed character passwords I use, so again, I’m puzzled with I read that a user’s password attempt using such won’t be accepted.  It’s a simple device with two functions…save a file, save it in a secure manner.  I find mind does both very well and have no issues with it at all.  Knightsix  

I can’t understand why you are experiencing such a problem. The package my TD arrived in was clear on time required for big files.  I plugged the SanDisk Secure Access TD into my CPU and got ‘instant breakfast.’  No hassles, no problems at all.  No, the individual files are not encryted.  You simply drag them into the valut icon, or bring up their “Add Files” screen and drag them to your folder there.  The ‘vault’ itself allows very robust mixed character passwords, and I have no problem there either.  It seems like we’re talking about two different units here, but apparently not, so I don’t know what computer or OS you’re using.  I have an HP Phoenix Pavillion H9-1130 CPU with an 8-core (eight 3.1ghz processors) Win 7 OS, and have experienced none of the problems this forum is speaking about.

I surmise that your Sandisk Secure Access Manager took so long to open because your anti-virus software was struggling to scan it.

Milo

Bear in mind that this is junkware, (I call it muddleware because it is just an advertising vehicle for the YooWaa on-line storage services, but made to appear safe to the average user).  It is marginally serviceable, and by no means rugged nor even documented.  They seem to leave it to ‘forums’ like this to excuse the poor documentation, and divert disappointed users.  It also requires you to move ‘secure’ files to an insecure storage area (outside the vault) to use them, and avoids providing any advice about cleaning up the inevitable insecure residue left by that handling.  The ‘documentation’ seems to have been written by several different advertising hacks, who had not read each others materials, nor significantly used the software themselves.  One says there are 3 ways to store (another 4). One says a single vault/folder is possible, but the screen sometimes offers ‘add vault’ & the login then shows a dropdown of your vaults (separate account folders in a public folder).  … If your environment permits, you might try something more substantial like BitLocker which has other limitations, but seems better done.