Audio books loading problem

Help! I am not a ‘geek’ but a 63 year old grandma who LOVES her MP3 Sansa! BUT I only use it to listen to audio books. If I load them into the audio book memory  I can’t get them to “play all” which leaves me fiddling in the dark in bed, for the next CD, or having to get up put on the light and look for my glasses, as font is too small to read without them. If I load them into “Music” to ‘play all’ the cd’s load numerically backwards! or in any random order it chooses!!! Fine for music, not so good for a thriller! which again leaves me fiddling about in the dark. Is there an answer out there? regards purplecow47

Message Edited by TomJensen on 05-03-2010 06:01 PM

@tomjensen wrote:

Tag management can be a hassle if you aren’t acquainted with it

I just used mp3tag for the first time that helps to enter tag infos to single or groups of files and it worked very well to sort the 36 chapters of my last audiobook. But I’m not quite sure which of the tags the Fuze uses as first sorting criteria - track-no. or file-name(?) - because I entered the chapter-no. into both.

Message Edited by notrabacho on 03-20-2010 06:45 PM

The track number is what determines the playing order within an album(files with the same album tag). If there are no track number tags, then playing order is determined by the title tag(not the filename). I guess if title tags are also missing, then it might sort them by filename. I usually just give all my podcasts in a series the same album name, and assign track numbers to them. I also use mp3 tag and select all, and use the command convert filename -tag, so that the title tag becomes equal to the filename(without the extension) for every file in the folder(which is all the files in the album). Some people might want to use this strategy for audiobooks as well. When assigning track numbers, use leading zeros, ie, use 01(2 digit numbers) or 001(3 digit numbers) for the first one.

@jk98 wrote:
The track number is what determines the playing order within an album… When assigning track numbers, use leading zeros, ie, use 01(2 digit numbers) or 001(3 digit numbers) for the first one.

Thank you for your verification of my speculation, saving me the hassle of renaming and reloading in order to find out the Fuze way of sorting. Assigning new track numbers was actually the first thing I did since the original ones from audiobooks consisting of more than one CD are of no use. But I also filled in these new track numbers at the beginning of the file name because this is the way I set up my PC.

Thanks for your reply, however it is not the tracks I have a problem with. It is trying to find a way for each cd to ‘follow on’ ie ‘play all’ without having to search for it, in the Audio book memory. I discovered long ago that computers are too logical! because with the older books I used to get CD 1 followed by CD 10, I solved that in my own way by calling CD 10, CD 91 CD 11, CD 92 etc. not very scientific but it was quick and it worked! well it works with a’ play all’ feature which my old Mp3 (5 years old) had. unfortunately the battery no longer charges so not so good on plane journeys anymore.

I don’t believe the Fuze can jump from one folder to another in Audiobook mode, although I’ve never tried this (of all my audiobooks, each only has one folder).

Verify this by playing the last file of one folder (FF’ing to the end), and see if it will auto-jump to the next folder.

If it can’t, then you’ll need to use a program called MP3Tag.

http://www.mp3tag.de/en/

. Download and install MP3Tag.

. Rename audiobook’s CD folders to correct sequence, e.g. CD01, CD02, etc (if no more than 99 folders).

. Make a backup copy of the book’s CD folders, in case something goes wrong with the below procedure.

. Run MP3Tag, and Change Directory (Ctrl-D) to the audiobook’s folder on the PC. You should see all the files in every folder. If the files are named the same for each, then you should see multiple instances of the same-named files.

. Select all files (Ctrl-A).

. From menu, select Convert | Tag - Filename (Alt-1)

. Enter %_directory% %_filename%   . Click OK. The filenames should now be prepended with the directory name.

. With all the files still selected: On the left-hand panel, enter the book’s name for the Title and the Album fields. Enter the author’s name for the Artist field. Select <blank> for the Track field. Enter ‘Audiobook’ for the Genre field.

. Close MP3Tag. Using Windows Explorer, move all the files renamed into a single directory.

. Copy this folder into the Fuze’s \Audiobook folder. The files should now play properly.

I don’t believe the Fuze can jump from one folder to another in Audiobook mode, although I’ve never tried this (of all my audiobooks, each only has one folder).

Verify this by playing the last file of one folder (FF’ing to the end), and see if it will auto-jump to the next folder.

If it can’t, then you’ll need to use a program called MP3Tag.

http://www.mp3tag.de/en/

. Download and install MP3Tag.

. Rename audiobook’s CD folders to correct sequence, e.g. CD01, CD02, etc (if no more than 99 folders).

. Make a backup copy of the book’s CD folders, in case something goes wrong with the below procedure.

. Run MP3Tag, and Change Directory (Ctrl-D) to the audiobook’s folder on the PC. You should see all the files in every folder. If the files are named the same for each, then you should see multiple instances of the same-named files.

. Select all files (Ctrl-A).

. From menu, select Convert | Tag - Filename (Alt-1)

. Enter %_directory% %_filename%   . Click OK. The filenames should now be prepended with the directory name. Click on the Filename bar twice to reorder the files to ascending order.

. With all the files still selected: On the left-hand panel, enter the book’s name for the Title and the Album fields. Enter the author’s name for the Artist field. Enter ‘Audiobook’ for the Genre field. When done, click on the Save icon to save tag changes.

. From menu, select Tools | Autonumbering Wizard. Enable ‘Leading zeros’ checkbox. Click OK.

. Close MP3Tag. Using Windows Explorer, move all the files renamed into a single directory.

. Copy this folder into the Fuze’s \Audiobook folder. The files should now play properly.

Message Edited by TomJensen on 03-22-2010 08:42 PM

Message Edited by TomJensen on 05-03-2010 06:00 PM

“I don’t believe the Fuze can jump from one folder to another in Audiobook mode”

In audiobook mode(browsing from the audiobook submenu), the folders you create are ignored. The files that are in the audiobooks folder or have the genre audiobook, and that have the same album tag are considered to be a book. The player will play all of them in a row. It is necessary to have the track numbers or title tags set properly so that the files play in the order you want.

Thank you very much for your help, I might though need a computer geek (my son) to decipher the instuctions. as I said I’m a bit old!! I’ll consult him and let you know the results. Again thanks for your time. regards purplecow47

Thanks for the instructions (and I’m glad I took the time to read them since I thought I already knew how to do this).  A real “DOH!!!” moment: I was doing the equivalent of this one folder at a time!  :stuck_out_tongue:   

(In my defense, I was tagging each folder as the next disc was ripping - but these instructions will change my process!)

@tomjensen wrote:

. Select all files (Ctrl-A).

. From menu, select Convert | Tag - Filename (Alt-1)

. Enter %_directory% %_filename%   . Click OK. The filenames should now be prepended with the directory name. Click on the Filename bar twice to reorder the files to ascending order.

Lately, I’ve been listening exclusively to audiobooks downloaded from the library (overdrive.com), and they already have ID tags set up properly.

Problem solved!!! thank you so much. with your tips and a firmware update the file now goes into Audiobooks ‘folders’ something I didn’t have before update. no more fiddling in the dark. much love purplecow47 xx

Thank you very much Tom Jenson i love Mp3tag!!! The instruction took a liitle sorting but even at my advanced years a being a Girlie! I’ve got there. I love the www Geeks expert out there. Love Purplecow xxxxxx

I recently received a refurbished Sansa Fuze as a gift.  I’ve downloaded the manual but it doesn’t seem to address a way to download an audiobook directly into the Audiobooks folder.  I’ve loaded the book onto the Windows Media Player and when I hit SYNC it does so right into the Music folder seemingly without a way to direct it into the Audiobooks folder.  Is there a better way?  Also having read this thread, since I didn’t tag any part of the download will I have problems from one CD to another?  It did self number the tracks 101-599 all the way through the end.  Is that enough to go through the entire book with out prompting it?

Suggest you post this in a new thread, rather than reply to a ‘Solved’ thread, to get better attention.

I always used drag & drop to get audiobooks onto the Fuze, so can’t tell you how WMP works. Perhaps another can point you the right way.

If you don’t tag the files, the Fuze will go by their filenames. As long as they’re in alphabetical order, it’ll work. As JK98 indicated, it will not skip to the next folder (assuming each CD is in a separate folder), so either you move them all into one folder, or you tag the files.

I use drag-&-drop to move the files into the Fuze’s \Audiobook folder, so can’t tell you how WMP works. Perhaps another here can tell you how. AFAIK, audiobook files are shown in the Audiobooks list by either having an ‘Audiobook’ tag in their Genre field, or by the physical copying of files into the Fuze’s Audiobook folder as mentioned above.

If you don’t tag the files, the Fuze will go by their filenames. As long as they’re in alphabetical order, it’ll work. As JK98 indicated, it will not skip to the next folder without proper tagging (assuming each CD is in a separate folder), so either you move them all into one folder, or you tag the files.

I use drag-&-drop to move the files into the Fuze’s \Audiobook folder, so can’t tell you how WMP works. Perhaps another here can tell you how. AFAIK, audiobook files are shown in the Audiobooks list by either having an ‘Audiobook’ tag in their Genre field, or by the physical copying of files into the Fuze’s Audiobook folder as mentioned above.

As a note, to get better attention when asking for help, make a new thread rather than replying to a ‘Solved’ thread.