Album order problem in MSC mode

Hi everyone

I’m having a problem with my Fuze. I don’t understand how to set up the files so albums can appear and play on the Fuze in the appropriate order. I first thought it used only ID3 tags to sort files according to track number, but it seems a bit more complicated than that …

Actually I hadn’t any problem with most of my albums (I’ve had the player for a couple of week), but now a couple of albums are tricky.

My files are properly tagged (I use foobar2000 to listen to them on my computer, which sorts them according to tags as well, and everything’s fine to him). I checked the files with The Godfather, thinking it could be a discrepancy between ID3v1 and ID3v2 tags. I did some sync between them just to be sure (and maybe a couple of random stuff I tried), and my tags appeared fine (exemple with an album) : 1 2 3 … 10 11 in ID3v1 and 01/11 02/11 … 11/11 in ID3v2. By the way does the Fuze have a preferred format for that ? (like the “/11”, does it like it ?)

My files are also named in a way that alphabetical order is album order : “01 - title01.mp3” … “11 - title11.mp3”

On the Fuze, the files first appeared in that order : 10 11 9 8 7 6 5 4 3 2 1. After playing with The Godfather, they appeared in that order : 1 2 3 4 5 6 7 8 9 11 10. Much better, but still with the last 2 songs inverted. The strange thing here is that they appeared in that precise order in The Godfather too (even with all tags fine, including tracknumber) when I first opened the folder in it, but they appeared in correct order after clicking on “Track” column label (to sort files according to track number … I have no idea how they were sorted before that !).

So, last thing I tried is a little trick I had found with my old player, which was sorting files in the order I copied them on the device (and Windows doesn’t copy the files inside a folder in alphabetical order, it would be too easy ! apparently a weird files order is stored in the filesystem or something). So the trick was : Create a new folder, take all the files in the old folder, cut and paste them in the new folder, delete the old folder, rename the new folder like the old one. And after that the files are sorted in the filesystem in alphabetical order, and  copied in the same order (worked perfectly for my old device).

So I tried this, and the files appeared in the correct order in The Godfather (even before sorting them according to track number), so I started to be optimistic … (but pretty pissed that I didn’t get rid of that annoying problem I had with my old device) So I copied the files on my Fuze again, and this time the order on Fuze was : 2 3 4 5 6 7 8 9 10 11 1. Not yet Fuze, try again !

I used MSC for transfer, so I tried with MTP and this time it worked fine ! But I don’t like MTP … How could I have all this working fine with MSC ?

Thanks for reading all this and for your help !


Read about ID3 tagshere. Sansas like ID3v2.3 ISO-8859-1. You can use mp3tag to fix everything pretty easily. 

Also, with mp3 tag, under Tools use the Auto-Numbering wizard with the second option, leading zeroes (01,02). The Sansa has trouble with track numbers like 1/12.