After conversion, Videos won't play

I’ve replaced my Sansa e250 two times now. The one I have now is a Sansa e250V2. (That’s what it says on the back, and if I can recall, when you turn it on, the screen looks a little different from the regular Sansa e250)

I tried using the first converter to convert videos, and they were sent to the “Photos” folder. But now that I downloaded the newer converter (supposedly Sansa Media Converter 2) it converts it correctly into my videos folder (and a difference between e250 and e250v2 is that e250v2 doesn’t use quicktime videos).

However, when I try to play the video, the screen wipes black as if it’s going to play the video. Then it freezes, only to have a little “square” in the bottom-left corner that shows the battery. I hold the power button for 10 seconds and it resets. Then when I start it back up again and try to play the video again, the screen wipes black completely (as if the video will play). Then it just wipes back into the menu like the video finished playing. IT DOESN’T PLAY THE VIDEO AT ALL!

I’ve tried reinstalling SMC but it still doesn’t work. I’ve also tried converting in MTP, MSC and Auto Detect Mode. And I’ve also tried to convert the video then drag it into the video folder, and it still does this.

This is getting very frustrating. Does anyone have some sort of solution for this, have the same problem, or recommend me to try something?


Just so we are on the same page, I have 2 questions:

  1. Is the original video playable on your PC?

  2. Do you have the latest SMC version (4.236)?  You can get it from here:

Yes, it seems I have the same version of SMC. However, I uninstalled mines and installed the one from your link, and it still does the same thing. My converted videos used to be playable on the computer (but not on the e250), but after I installed the one from the link, they don’t play at all anymore.

Oh, and I noticed that when I upload the videos, before I convert, when I play the video in the little player, I can’t hear any music. Maybe that has to do with it too?

Any suggestions anyone?

I have a similar problem with my e280. SMC turns my MP4 into a MOV fine, but the MOV file plays the sound with a black screen, whether it’s on my computer using QuickTime or on my player itself! What gives?