32GB Sandisk Micro SD suddenly stopped being recognized by Galaxy S3 phone

I am so frustrated with this Sandisk 32GB SD Card. Suddenly my phone crashed and It stopped getting detected by the phone or PC. They are giving an option of formatting the card. Even after formatting it is showing Blank card. Can anyone help mw to recover all my favorite pictures. This is so sad. I have all my travel pictures in the card. Please please help if the data could be recovered, Thanks.

Tirthaa

+971557020149

Same thing just happened to me on my Galaxy S3. I bought my card at Costco and I just returned another one for my friend last week. It bothers me that SanDisk has not put a comment on this thread when it is obviously happening to a lot of people. 

Both my Note II and my wife’s Galaxy S3 had experienced the same problem.  don’t know what was going wrong to ScanDisk product…!!!

Did anybody read through all posts in this thread? Particularly #6?

I wouldn’t be so hasty to place blame on the card when there are reports other brands are affected as well. It is just as likely (and probably even more so) that the phones from Samsung are at fault.

1 Like

What I did with mine was I just left the card in my Galaxy S3 and it eventually was able to read it again. When it did, I immediately connected it to my PC and transfered all the files over. I will now format it a couple times and return the card to Costco. I would recommend this to those of you who didn’t have backups of your files prior to the card going to crap. Give it some time and keep monitoring the device and backup if/when your card is readable.

Good tip from yakyuboy.  I did the same late last year on my S3 for my Sandisk SD 32GB.  

I replaced it with a Samsung SD card, so that if the same occurred, I could only blame Samsung!  However, I haven’t had any problems since then.  Recently, I tried the Sandisk in my new Note 2, and after a week, the SD decided to die (again)! :frowning:  won’t be buying Sandisk for a while!

Same problem.  After 6 months of use SanDisk 32gb micro sdhc failed.  I am trying to recover my photos and data from it now.  Judging by this forum, it is obvious that SanDisk is well aware of this problem… they just don’t care.

Its funny how the SanDisk so-called “guru” (employee) is quick to blame other companies and offers no solutions. 

I hope that all of you reading this learned the same lessen I have and NEVER buy anything from SanDisk again.  Warn others, remember to go to New Egg, Amazon, and Tigerdirect to post reviews.

@none4u wrote:

 

Its funny how the SanDisk so-called “guru” (employee) is quick to blame other companies and offers no solutions. 

 

“Guru” status on this forum has nothing to do with whether one is an employee of SanDisk or not. And for the record, I am not.

Furthermore, I was not “quick” to blame other companies. At the time I replied to this, there was speculation (by others in other forums) that the fault did not in fact lie with SanDisk memory cards as other brands of cards were also affected. The one common thread was that all these failures (or at least the overwhelming majority) occurred while using the cards in Samsung phone and devices. I merely suggested that one should not be so “quick” to place blame with SanDisk memory cards when there is substantial anecdotal evidence to the contrary.

As far as offering a solution? I am neither a SanDisk nor Samsung employee so it stands to reason I would have no potential solution to offer. And criticizing one of being “quick to blame” when you appear to be doing the exact same thing seems a bit ironic, don’t you think?

Had a problem a while back reading Sandisk Ultra 32GB MicroSD card (birthday gift) in my Samsung Galaxy S3… taking the card out and reading it on PC to get the photos/videos off did work, but card wasn’t reconized when returned to the S3… until I put it back in with the phone on.  Worked for several months fine, but recently the card failed to be recognized by the S3 and now isn’t recognized by any of my PCs. 

Found this link that Sandisk had some problems… http://www.phonearena.com/news/SanDisk-says-it-produced-some-bad-32GB-and-64GB-microSD-cards_id40986 but not sure how to get a replacement.  Maybe mine was doing what the one comment there said of continuously remounting/rescanning and that’s why my battery would sometimes be drained quickly.

I was thinking about getting one of these [SanDisk SDSDU-064G-A11 64GB Ultra SDXC UHS-I Card 30MB/s (Class 10)](/t5/forums/replypage/board-id/all-cards-readers/message-id/SanDisk SDSDU-064G-A11 64GB Ultra SDXC UHS-I Card 30MB/s (Class 10)) until I found this comment thread.

Anybody from Sandisk read these comments?

Chatted with Sandisk online (through their Contact Us page) and am already approved to begin the process of replacing the 32GB Ultra MicroSD card that went bad in my Galaxy S3.  Am impressed by their speedy response.

Same problem here…Was the issue resolved???

Yeah.  This is total crap.  Complete LACK of responsiveness on the part of San Disk.  I have seen no posts resolving this anywhere.  Nice customer support.  I have a Galaxy Note 2 which just decided one day to randomly not recognize the stupid SD Micro card and now all music and everything else must be re-loaded.  WHAT A PAIN IN THE A$$…

How’s the responsiveness on the part of Samsung? Since this is only happening on their products, seems there’s something their phones/devices are doing to kill the cards.

1 Like

Not just Samsung - had the same problem with my partner’s Blackberry 9320 - 32gb Sandisk Micro SD card  just stopped working; not recognised and can’t access any of the content on there. It’s the reason I am on this forum; just registered to post this.

I bought the 16GB Galaxy Note II International Version when it first came out. Bought a 64GB SD card the same day for it. Been using them with no problems ever since. But the past few weeks my phone has been freezing and forcing me to take out the battery. It continued to happen more frequently until for the past few days it would happen at least a few times an hour. Even though I had factory reset it multiple times.

Anyways, I was at the gym today getting ready to dumbell press, I was listening to music through my apple earpods and my phone, which was in my pocket. I leaned back onto the bench and my phone slipped out of my pocket and the headphone jack came out of the phone’s socket. When I put it back in, I couldn’t play any music, then I noticed that it said that there’s a blank card inside. I tried “turning it off and on” and removing and reinserting the SD card but to no avail. Now it’s 12AM, I factory resetted my phone again and the SD card is STILL not working.

I would format it if I didn’t have my bodybuilding progress photos of myself from last week on it, I just can’t have them gone forever, as I’ve been taking accurate weekly photos for over half a year now nonstop and can’t miss a single week.

I’m hoping for a miracle to happen and for it to fix itself.

I can be contacted at max@grand-direct.com

If you’re reading this and you have the same problem, then register and post about it. Don’t just keep quiet. The more people talk about this, the more likely someone will find a solution.

Wow… I thought I was a one-off kind of person until I came across this thread. I also bought a SanDisk Ultra 32GB microsd card for my S3. Recently I too got the message that my SD card had been successfully removed…but my phone was sitting there in the case and all. Honestly I thought it was just a blip, a momentary loss of connection or something. I realized today that all of my data is gonzer. I tried to reseat the card, reboot the phone, even removed the battery, but all seems to be a lost cause. I plan on going home and giving the PC a go at it, but after reading this thread I am hesitant that the pc will have any additional success.

What’s sad is that only 1 in 10 unsatisfied customers ever voice a concern. Based on this statistic, this issue is not uncommon. =(

Bought SanDisk 32gb microSDHC UHS-I card(for mobile devices) around October 2012. The card worked flawless until 2weeks ago when I suddenly got a notification “bad removal” “card ejected” (the card never left the phone since the beginning). Already familiar with the tons of complaints (xda,Samsung, Sony- forums) regarding this type of card I began to fear the worst and after struggling for 2 days it just gone blank. No device that I triedsees the card. Also the pc can’t see it anymore.
28gb on video, documents and pictures, all gone.
The most people I read here on the forum mentioned they owned a Samsung device. I do not.
I own a Sony Xperia T (lt30p) with stock android 4.1.2 jelly bean, not rooted.

In those 2 days I had the card monitored by an app and only one time I had the phone restarted(counts for 1 mount and 1 unmount.
The following stats where logged:

Card mounted: 14 times
Card unmounted: 32 times
Card bad removal: 10 times
Card removed: 3 times
Card ejected: 23 times

Also a lot of other Sony phones have problems regarding these cards failing.

The following I count as just speculation as I can’t find any official statement by SanDisk regarding this problem.
I’ve also read somewhere that SanDisk is aware of these problems and even admitted that a faulty batch went on the market before noticing that there was an bug.

Next monday i’ll phone SanDisk and see what they have to say.
I see my data as lost in the meantime.

Hi,

    I am also facing the same problem, I bought a Sandisk 32gb Micro SDHC card with class 4. it was working good till one month.but now It is not detected by my android phone.So I tried with card reader result is same.Then I try to connect it through a USB card adopter to my PC. It asks for Formatting the removable disk.When I try to format it in basic FAT,NTFS or exFAT it shows only 30.6 mb capacity and a prompt message “Windows was unable to complete format”. 

Please Help!

After someone telling me that there is a known problem with some Sandisk micro SD cards and Samsung phones, I searched and found this. Same symptoms, phone started freezing up, requiring battery to be removed, fast battery drain, and eventually the SD card couldn’t be read any longer! Now if you try mount, it says its blank and suggests a format.

Putting the card into WinXP machine, Win7 laptop, Raspberry Pi with 3 various micro  SD card readers which are working with other cards just fine … nothing, can’t see the card as a drive. Have tried all sorts to try recover the data, nothings working.

It’s a SanDisk 32Gb Class 4 … less than 1 years old :angry:

Not about to send the card off for a replacement as there is still data on there … I just can’t see or get to it due to cards HW failure.

1 Like