32Gb Cruzer Spark unable to format


I have this USB stick which I’ve copy some music files to play them in my car, I erased them a few weeks later and now I can’t copy any files on it. I can’t even format it. I’ve tried with diskpart with no success, AOMEI: same results.

The usb always appear in Disk Management, but I can’t even delete the partition! When I start the format process I don’t have any % of progress… I tried on other PCs with same results…

This is the second Sandisk USB thumb drive with that problem. I wrote thoses files just one time! So there was not a great usage on this drive… I talk to Tech support and they suggested me to get an RMA, but I don’t have any proof of purchse anymore (though that Sandisk was a great product…) So I want to try everything to repair it.

Thanks in advance

I’m pretty sure the RMA doesn’t require the sales receipt.

It is stated at the line when they required a picture of the product… But I will try it anyway… If not I will just try Kingston…