32 GB pendrive isn't showing in Windows 10

Hello. I’m owner of 32GB Sandisk Ultra. My pendrive for some reason isn’t showing in the explorer. I checked the Device Manager and the pendrive has no problems. So i checked Disk Managment and is also showing. I pluged it to my old laptop with Windows 8.1 and it’s works fine. I tried everything and it wont work.

The current machine may not assigning new letters, do the following >>

 Open Command Prompt with Administrative privilages >> Type  diskpart  >>  list disk  >> (If only 1 disk on the machine, do  select disk 1 __) >> assign letter= letter of your choice

Check if USB massive storage device is enabled. Go to Device Manager > expand Universal Serial Bus controllers > right click USB Mass Storage Device. make sure it it enabled.
Or, update the device driver also in Device Manager.

I have a similar problem with my Extreme Pro 512gb. At first it doesn’t appear in the explorer or eject option, I wait a few minutes and it appears !. I tried another pen drive (Corsair) and it always appears instantly, weird.

try to backup the registry,follow the steps

  1. Unplug the device from the USB port.

  2. Run regedit .

  3. Window 10: Type regedit , in the ‘Search the web and Windows’ field (lower-right) and then select ‘Regedit - Run Command’.

  4. Windows 7, 8 and Vista: Click the Start button, type regedit in the search box, and then press Enter .

  5. Windows XP: Go to Start > Run , type in regedit and then click OK .

  6. From the registry menu, choose File > Export .

  7. Name the file SNDK.reg and save it to your desktop

Why backup the registry ??, that will solve nothing.