3 Cruzer Glide 3.0 16GB not recognized by my computer

I bought 3 of these at Costco. None of them are recognized when I plug them into a USB 3 socket. They simply do not exist. I have tried windows disk manager and two different third party partitioning programs. NADA.

How do I fix this? I am on a time critical update. I need these to work.

PS - I do not buy the “oxidized contacts” thing.

And why does this site block my spell checking app?

I rebooted for another reason. Now I see the flash in disk manager with an system assigned drive letter. No idea why it changed.

I don’t believe I took any drives out without going thru the eject procedure. And I tried initially in the usb port I was using and one I was not.

Anyway; I can move on. I am trying to go from Win 7 oem to Win 8 retail to win 8.1 to Win 10 before the freeupdate expires (to keep apps and settings).

FWIW I upgraded  from 7 to 10 directly.  And everything that worked with 7 works with 10.  It did take hrs for the upgrade to run and it needed a lot of disk space.