Cruzer Glide 32gb used to work, doesn't anymore

I bought this a couple of months ago and didn’t get the warranty with it. It worked fine up until yesterday.

Now it does one two things

  1. Fails to show up in My Computer, but does show in device manager under Disc Drives and in Universal Serial Bus Controllers as  USB Mss Storage Device. 


  1. Shows up in My Computer. Going into it yeilds a blank folder. Rght Clicking and going into properties it shows 0 byes of used space as well as free space.

Type: Removable Disk

File System: Unknown

I tried formatting it (i’m counting the files as a loss, but i have backups so that’s fine) but right clicking on the drive and clicking format does nothing. No format menu, no error, no processes started as far as i can tell.

Whenever remove it i always use the Safely Remove Hardware and Eject Media beforehand.

It wasn’t full spacewise. It was about half full, maybe a little more.

Tried it in my other computer. Same result.

Attempted to update drivers but it said they were up to date already.

My other usb drive (Cruzer 8gb) works fine.

I’m runnign Win7.

Any help would be extremely appreciated

When you see it in device manager have you tried to manually assign a drive letter to it?  Windows is notorious for assigning the same drive letter to multiple devices and sometimes that doesn’t work.  I suspect your 8GB drive got the 32GB drive’s drive letter assignment.