240GB Sandisk Extreme problem erasing data

Hello, I am new to ssd’s and I am having a problem with my new ssd 240 BG extreme for my early (4,1 model) 2008 macbookpro.  The problem is that I first cloned my old HD to the ssd, and almost filled it out.  I only had 15 GB of free space, then I erased some files that were about 50GB.  On the finder it says that I have 65GB of free space, but if I open disk utility, it says that I only have 15Gb of free space.  When I tried to install bootcamp, the bootcamp utility also only reported 15 GB of free space, I researched a little bit and found out about the trim enabler, I installed it and ran it enabliling the trim.  I re-cloned my old hd to my ssd and the problem persists, I still can’t claim the space from the erased files.  My firmware for the ssd is R201, I tried to flash the ssd with the new firmware but was not able to, it does not boot into the firmware upgrader, I tried with a cd and with a pen drive and nothing.

Any ideas on how to reclaim the free space??


Jonathan Zighelboim

did you empty the trash once the files were deleted? if not MAC does not free the space. 

Hello drlucky, yes, I did empty the trash.  

From what I have seen in the last week, the ssd is deleting the data, but only if it is small amounts, for example, if I erase a 10 mb file it does the job correctly, but if the file is big, 2 gb, then it does not erase it porperly, as I stated in my original post.