WMP Will Not Sync & Gives Error Message (8GB internal/32 GB external)

I have an 8GB Sansa Fuze w/micro SDCH 32 GB card inserted (bought card after reading it could be used). 

The card and size amount shows up correctly in WMP, Explorer and elsewhere.

The player shows I have 1 G available on the internal memory and 13 GB on the 32 G card.

When I have tried to sync new music I get the following message…

“WMP cannot access the file.  The File might be in use, you might not have access to the computer where the file is stored, or your proxy settings might not be correct.”

It is not a WMP issue - I have tried syncing with another Fuze player and WMP works fine.  I have also tried syncing music on this Fuze on another home computer and get the same message.

Any ideas why these programs are showing 14Gb available but the Fuze will not allow syncing or copying. 

Also, I have the player on Autodetect and have used this Fuze for several years now. 

There are 5200 songs on this player.  I am begining to wonder if this Sansa Fuze really can’t work with a 32 Gb card.  At one time I did format the card with Windows 7. 

Any ideas?

Thank you…

First, test the card with this, just to make sure it’s legit:


Now, with the Fuze connected, go into the settings of WMP. Look at Rip and Sync. Rip should be mp3–NOT copy-protected .wma, the default. Thanks to greedy recording companies, WMP is suspicious of external cards because you might lend them to a friend and become an EVIL COPYRIGHT PIRATE. Copy-protected WMA files are not portable. But mp3 files are. So change that Rip setting from .wma to mp3 (at 192 kbps or above for good sound quality) and see if it helps.

The original Fuze has a song capacity of 8000 tracks. 

To attain this capacity, first be sure that you have the latest firmware installed on the device.  The original Fuse was produced in two versions, with an updated processor, so first check your version via Settings > Info.  The forst two digits of the firmware designator will tell you if it is a version 1 or 2.

Here is the firmware thread for you.  Note that if you install the Sansa Updater listed in the thread, you can also update the device automatically.  The manual process is also very simple, just be sure to unzip or extract (Windows 7 has an automatic “ectract” feature) the firmware file prior to installation.

Both the odd Windows Media Player message, and the capacity issue, should be solved by using the built-in format command on the player itself (this is different from the Windows format command from the PC).  Before doing this step, be sure that you have backup copies of your music, as it will clear the internal memory portion (not the microSD card) in your device.  You will find the command at Settings > System Settings > Format > Yes.  This will optimize the internal memory of your device.  You will only have to do this once.   In the future, you can format from the PC if needed.

I would recommend removing the microSD card during this process, then mount it afterwards.  The music database will refresh, reloading references to your music files on the card, this time from scratch.  One additional thing that will happen is the Windows Media Player information on teh device will also be built anew when you sync with Windows Media Player.

Oh, and one last thought, definitely check the 32GB card as mentioned above.  Sadly, the 16 and 32 GB cards are notorious targets for counterfeiters (as folks look for the larger capacity cards).  The h2testw utility is great stuff.

The Secure Digital part of the micro SD card is often overlooked.  As long as it is mounted in your Sansa, and you use MTP mode, the files will play on your device even if protected media.  The device recognizes the card as yours, and files transferred between your PC and Sansa have matching keys (if encrypted / protected).  Of course, if the files are basic MP3, they will play regardless.

Bob  :smileyvery-happy:


Are you suggesting to get the player to fully use the 32g card, I should format the internal card?

Also, I have version 1 and up until a week or so ago, I used a 16g card just fine and was able to sync just fine. 

The program suggested by the two of you was used and shows the card still has the remaining space on it and I only have 5200 songs on the player as it is. 

Also, the player will not let me sync on either the internal’s remaining space or the micro card.  Oddly, I’m wondering if this player will only accept a 16G card because that is just about the amount of space used on the card before the WMP error message started.

I have noticed other people have received the same message. 

Thank you…

If you don’t have the latest firmware, do the update. Might as well. Don’t bother with installing the Updater, since there won’t be any more updates. Just use the manual method.

Sometimes, for mysterious reasons, formatting the Fuze helps the external card work better. Don’t ask me why–might be stray bits of information floating around from many syncs.

But as long as you have copies of the content, it’s worth a try. Take out the 32GB card before you format. 


Thanks for the format solution.  That worked for me.  Now it’s filling up the 32 Gb card…thanks again