WMD 32GB will not allow a unique SSID and Password to be set up

Sir / Ma’am,

I have received a new WMD 32GB.  I updated to Firmware 3.04.  I was able to reset the Admin password without a problem.  However, the unit will not allow a unique SSID and/or Password to be created for its own network.  I typed the info into the Settings/Change Wi-Fi Settings page, with WPA security selected.  It will allow me to type the info in to the data fields and select Done.  But then provides the following error message.  

“Error:Fail   Action could not be completed.  Please try again later.”

I also tried to only set a password, with WPA, using the default SSID name (“SanDisk Media 6B23”).  This did not work either.  I have attempted this over the course of a couple of days.  The unit is fully charged.  It has no problem connecting to my home Wi-Fi network.    

Additionally, on my iPad’s device Settings/Wi-Fi page, the SanDisk Media 6B23 is visible and connects without a problem.  But it says “Security Recommendation” under that network name.  I’m assuming that is because there is no password set.  

I need for this unit to be secure before I am able to use in public.  Any suggestions?  



I would suggest resetting the WMD. If the same occurs it may be defective and may need to be replaced. 

Reset instructions. Try the 10 second reset. if that does not work try the 25 second reset


drlucky…   Thanks for the suggestion.  I tried both the 10 second and the 25 second resets.  Neither fixed the problem.  

drlucky… Ok, I called SanDisk and they figured out the problem with me on the phone.  The Wireless Media Drive passwords will NOT accept any special characters or spaces.  Numbers and upper & lower case letters only.  Same for the SSID, except spaces are Ok for the SSID.  Hope this helps anyone else who may read this.  

1 Like

My Stick don’t connect to my phone tells me all the time connect ! I have hundreds of pictures very precious ones on the stick I deleted the app and reset it new upgraded my phone but it still won’t let me in I’m pretty angry can someone Help me

Is it possible to reset my stick and get on my pictures and videos back what can I do I’m not very technical and tried hard to save my pictures ! I got 32 GB and at least 300 precious pictures on it please help

Please provide me with a phone number so that I can maybe ring up thank you everyone I’m very upset customer

if you have a wireless stick you are posting in the wrong board. probably best to call sandisk support at this point. 866-SANDISK

how to setup password ?