Why when I just want to charge my sansa clip+4gb; it copy all my files from the computer ?

Hi everybody,

I’ve bought 3 days ago a sansa clip+ 4gb, I really like it but I don’t understand something.
The first time I’ve plugged it on my computer to charge it, It started by itself to copy all my songs from the computer and I did not know how to stop it ! I’ve let it finish it, or almost then I’ve unplugged it.

Now 3 days later, I’ve decided to organize my folders and songs, but when I’ve plugged it, it started again and continued to copy all the songs from my computer without asking me any questions… I just wanted to selec by myself what I wanted to copy and I did not want all of them !!

How can I do to stop the “writing process” and do it by myself (song by song) ?
It means so that everytime I will have to charge it, it will copy again and again everything ?

Thank you !

You’ve got your player set to MTP (or Auto Defect which is kinda the same thing) and Windows Media Player set for Automatic Sync (On by default). Change your sync settings in WMP or switch to MSC mode on your player. Either way, you should format the player (Settings > System Settings > Format) to clear the memory. In MSC mode you can manually copy the files you want from your computer to your player, and WMP won’t bother you any more.

The player isn’t doing it, software on your computer is. A likely candidate is Windows Media Player. It’s trying to “sync” the player with your music library, meaning it wants to make the contents of the player match the contents of the computer. Go into WMP’s (or whatever program is doing it) settings and turn off autosync.

Disable whatever software you’ve setup to sync it.  WMP perhaps?

Ok I did what you told me, I mean I stop the sync from WMP and it worked perfectly !

Thank you so much I can finally add what I want  !  :slight_smile:

I’m a new user. I use foobar on PC.

I have re formetted my Clip+, Set USB mode to WSC and stopped WMP syncing automatically.

However every time I insert the Clip+ USB lead into the computer it still always starts the set up sync in WMP dialogue.

I can simply click close but is their any way to stop the dialogue starting at all?

I’m frightened it will get started by accident again.

Thx.

Doublecheck in WMP that you have disabled Auto Sync everywhere a setting might be hidden.

You can also–and I recommend this anyway–disable Autorun of all removable drives. I hate programs starting themselves when you plug something in. It’s also good for security, in case a virus gets on a USB drive and Autoruns itself when you connect it to your computer.

Here’s a simple how-to:

http://www.howtogeek.com/howto/windows/disable-autoplay-of-audio-cds-and-usb-drives/

If you go directly to Microsoft, they make it look complicated, and it’s different for various operating systems, but it’s really just a few steps. Ignore the geek boilerplate and scroll down to the instructions for your operating system on this page:

http://support.microsoft.com/kb/967715

Thanks for trying  to help.

The howtogeek tip doesn’t work for me as I only have Home Premium and you need the more expensive versions to enable gpedit.

I cannot find anywhere in WMP to disable AutoSync at all. It doesn’t have a preferences. You can stop it syncing some libraries and playlist but it always trys to sync MUSIC and I cannot find a way to disable that. Maybe I could delete all entries in MUSIC but that would be inconvienient.

The other link also refers to gpedit which I don’t have. Since I already have ‘use autoplay for all devices’ unchecked I cannot see what effect editing the registry to stop autorun for USB removeable devices will do. I will have a go tomorrow if I cannot find another way.

It this how the device usually works for other users? Do you really have to avoid hitting enter and moving to click on cancel every time you plug the clip into a USB slot or risk corrupting you music library?

Phew. I think I’ve sussed it…

run > services.msc  > change the ‘portable device enumerator service’ startup type to disabled.

Dunno what knock on effects this might have but it stops the WMP auto starting the set up dialogue.

I couldn’t figure out a way to stop WMP in Vista at all. Could stop i but it always anaged to get back into the startup list when windows reboots.

No, you should not have to deal with this every time.  This is what happens when trying to make something “idiot-proof” and automatic ends up making it idiotic. 

Vista is a nightmare, HP especially, but if you have Autorun disabled—nice find!–that’s not the problem.  Instead of completely disabling portable device enumerator, you might try making it manual in case you want to plug in a storage drive or something.  Experiment–you could always disable it again. 

WMP is is the problem. 

With your Clip+ on and disconnected, go to Settings/System Settings/USB Mode and change it to MSC. That should make it behave like a basic thumb drive rather than a device controlled by Windows  Media Player. MSC should stop the auto-synching.

If you want playlists and such, you can make them through Winamp and probably even through WMP, but I just won’t touch that program, because it does the kinds of things you describe. 

But you should also put a short leash on Windows Media Player.  Have you tried Run…msconfig and those Startup and Services tabs? I don’t see WMP in my Startup. 

I’m on my Windows 7 computer now, where WMP makes it almost impossible to find its options.  They keep moving them around; in this version it’s under the Sync tab, but it may be different in your Vista version. You should try going to support.microsoft.com, which should detect your Vista operating system and give you the right info.

On this Windows 7 version, the device has to be connected and you have to go to the Sync tab–quick! stop the sync!–and then you have to set it not to sync. Awful. Hope yours is different. 

Here’s the Microsoft Q&A I found. 

http://windows.microsoft.com/en-US/windows-vista/Windows-Media-Player-Sync-frequently-asked-questions.

Somewhere in your WMP there should be a setting not to auto-sync music. You may have to do it with each device–I don’t know. But try the MSC fix first. 

It should all be easily handled, within WMP itself, once you find where WMP puts the sync option and you turn it off.

Sure. But Likesay. I’m done exhausted looking.

You always have this nagging suspicion it’s right in front of you but I’m done for now.

You really shouldn’t have to edit the registry or stop and start basic services to get something this simple to work properly. You never know what the repercussions will be down the road.

So since I’ve no intention of using WMP it leaves 2 choices.

Buy one of those after market USB power wall warts to charge it. Then it only needs connecting when you are concentrating on loading it. Then If it still proves to be a problem it’s going in the bin. I’m old enough to have realised that something that’s ebay only and costs $25 will be **bleep**. Quality costs money.

Thx for trying to help chaps.

@leightonbeck wrote:

I’m old enough to have realised that something that’s ebay only and costs $25 will be **bleep**. Quality costs money. 

 

I disagree. Sansa mp3 players are very good values and enjoyed and trusted by millions of satisfied users. Testimonials to this fact are found all over the internet. Just because you may be having an issue with a MicroSoft piece of software that the general concenus of users agree is bloated, quiky and downright lame, doesn’t mean the fault lies with the player.

Sorry OP, but you just need to buck up and look for the WMP sync setting within WMP and turn it off.  I wouldn’t imagine it should be hard to find.  But I avoid WMP.

And if you don’t want to use WMP, don’t–I’ve simply been copying and pasting content onto my Clips for years and it simply works.   ;

Sorry LeightonBeck, but you just need to buck up and find the WMP sync setting within WMP and turn it off.  I wouldn’t imagine it should be hard to find.  But I avoid WMP and so am of limited help as to it.  You might check with WMP users.

And if you don’t want to use WMP, don’t–I’ve simply been copying and pasting content onto my Clips for years and it simply works.   ;)  The fact that WMP can be a bit confusing doesn’t reflect on the Clip player–it reflects on the big Microsoft . . . .

And the information found for you:

How to find and disable sync with WMP 12–2 ways (at least):

1.  With WMP up and running and the Clip connected to your computer, press Alt to get a menu, choose Tools, then Options.  Choose the Devices tab, and then highlight the Clip and click on Properties.  You then have a Sync tab and sync settings to do/un-do.

or

2.  With the Clip connected to your computer and WMP up and runnig, click the Sync tab at the right side of the main WMP screen, and then click the Sync options button below that.  At that point, it appears that you can select the Set up Sync option and go through that (but I didn’t try going through the process, as I didn’t want to chance WMP setting up sync for me when I don’t want it).   

Hopefully, that will do it for you.

Sorry. I was out of order. Thanks for being civil about it.

The enumerator trich works o.k. to get me started. I’ll have another go later.

Suspect the problem relates to the fact that as far as my Vista HP64 system is concerned every time the clip connects it is seen as a brand new device which needs to go through a setup procedure all over again.

Thanks again.

Are you sure the player is manually set to MSC mode? WMP usually doesn’t try to sync or self-load in this mode because your computer sees the player as any other ‘dumb’ flash drive or memory space. It’s only when the player is in MTP mode, the computer sees it as a ‘musical device’ that must be mangaed and therefore launches WMP and starts to sync.

If the player is set to the default ‘Auto Defect’ (lovingly re-named) it will connect in MTP whenver possible and cause the same behavior.

@tapeworm wrote:

Are you sure the player is manually set to MSC mode? WMP usually doesn’t try to sync or self-load in this mode because your computer sees the player as any other ‘dumb’ flash drive or memory space. It’s only when the player is in MTP mode, the computer sees it as a ‘musical device’ that must be mangaed and therefore launches WMP and starts to sync.

 

If the player is set to the default ‘Auto Defect’ (lovingly re-named) it will connect in MTP whenver possible and cause the same behavior.

Great points–never had WMP try to sync me, perhaps because I’m always set in USB MSP mode.

Yes. 100% positive. That’s why it’s so frustrating to solve.

I know you think I’m an idiot. I probably am. But I’m an idiot with a clip set to MSC mode that doesn’t then act as a dumb flash drive. In fact even dumb flash drives are treated as audio devices by my system as currently set up. No idea why or how.

I shall get to the bottom of the mystery.