Why such of difference in speed?

I have the Sandisk Ultra 480g, Why am I getting burst speeds of 350mb and average of 300mb when Its advertised 550mb? I’ve used HDTACH and crystalmark to bench it. I’m using a SATA3 port, what gives? Thanks

300 to 350 range seems like SATA 2 speed. What kind of MB and SATA controller are you using? Also what SATA driver?

I have the Gigabyte zx77ud5 motherboard, It has SATA2 and SATA3  ports, prevously I used the Intel raid for 2 velocirators in Raid 0, I just have the Sandisk installed and using the whatever windows 10 installed? What should I’d be using?

Is this the MB you have? I cant find the exact part number you provided


If so this board looks like it has 2 different SATA 6Gb chipsets. One is Marvell and the other is not listed in the specs. You may want to try the SSD connected to both and see which gets better speed. The board also has SATA 3Gb ports so make sure you are not connected to one of those. 

AS for drivers check the MB manufacturers website and see if there are any updated drivers you can try. If the MB has an intel chipset use the intel RST AHCI driver. It has the best performance. If the board does not have an intel chipset you will have to use what the MB site provides or the Microsoft driver. 

1 Like

That is the Motherboard that I have. It has 2 controllers Intel and the Marvel conroller, I know I have it set on AHCI, but haven’t tried the other controller. I know when I was using Raid with my Velocirators I used the Intel and not the Marvel. I’ll change SATA ports and see if there’s a difference. Thanks for the help so far!

I switched SATA ports and now I’m getting the speeds I expected from the drive, I’m getting 530mb reads and 480mb writes Its not the 550mb/500mb advertised, but I’m satisfied with the performance! Thanks!

I ran CrystalMark Its reading 549/490 which is right on what is advertised for this SSD:) Definitely satisfied!

Just to add to the confusion… My Supermicro motherboard has SATA2 ports.

But I’m getting 510R/496W in a 2 drive Raid 0 array… with SanDisk 480G Ultra II  disks with dis-simelar firmware on them.

I was expecting to see ~350 but I’m seeing far more…

Using AJA SpeedTest (Video Editing) Utility set for 1920x1080 8 bit.