why do my audiobooks only have half a track?

hi im really hoping someone can shed some light on this, ive put a 10 hour long audiobook on my sansa clip+ thats about 700mb, why is it only letting me listen to 43 minutes of it? is there any way around this? i bought the mp3 player to listen to audiobooks but any i try i dont get the full book. tried with different audiobooks, even tried putting the files in podcast folder. :frowning:

You should be able to listen to a 10 hour audiobook.  And far more than 10 hours of audio of any sort. 

But there are a lot of different kinds of audiobooks, so we’ll need more info to help you.

What kind of an audiobook is it? From a library system like OverDrive ? From Audible? Ripped from a CD? 

(If you got it from OverDrive, you need to have the OverDrive Media Console on your computer and transfer it to the Clip that way. You can’t just drag and drop. You should also go to Settings/System Settings/USB Mode and make sure it is MTP. MTP sends over the secret hidden codes to unlock the book. So definitely try that if it’s an OverDrive book.)

Can you see what kind of files they are? Are they .mp3, .aa., .wma, .aax? Some other filetype (.m4a, .flac, .wav)? 

If you are in Windows you may have to set Windows to display (or un-Hide) file extensions. Go to the Help file and search “known file extensions” to find how to set that in your version of Windows. 

Let us know what kind of Audiobook and what kind of files and how big they are if you can. 

Thanks very much for your reply, the audiobook was downloaded from YouTube and converted to mp3. If I look at the track info it shows
Codec mp3(id3v2.4)
Duration 00:41:39
Size 553.12mb
Bit rate 138kbps(vbr)
Sample rate 44100hz

Seems strange that the duration just doesn’t match up. I’ve been listening to the exact same file on my iphone today with no problems.

Other books go to 2 hours, 3 hours and one nearly even gets to six hours long before ending short of the actual 8 hours.


So it’s not an audiobook, it’s a giant mp3 file.  It just might be too much information for the Sansa’s tiny little brain to handle. Most audiobooks arrive as chapters that are much smaller, and of course albums have separate tracks.

Also, what program is converting the YouTube to mp3?  It may be making mp3s that are slightly incompatible with the Sansa.

Here are some things I would try.

One problem might be the ID3 tags. Sansas don’t like ID3v.2.4, they like ID3v2.3 You can change the tag version with mp3tag.

http://www.mp3tag.de/en/  Make sure you download the mp3tag(version)setup.exe, not any of the other Download buttons you might see on its page.

When you install mp3tag, allow it to add itself to Context menu (option during install). Open it, and under Tools/Options/Tags/Mpeg, select  Write as  ID3v2.3 ISO-8859-1. (The ISO is Windows encoding for the text of the tags.)  Right-click on the mp3 file, highlight it in mp3tag, and Save to change the tag version. I don’t know if it will cure the problem but it might help.

I also see that your book is a VBR (variable bitrate) mp3. I’ve never had a problem with them but some people have complained that Sansas don’t like VBR. If you have a choice in your converter program, make it a CBR (constant bitrate) of 128kbps or 192kbps.

You also might try chopping the giant file into smaller chapters. The free program CDWave can find pauses and suggest edits–it’s good for albums, where there are breaks between tracks, not sure how it would respond to speech.


Audacity is also good for sound editing.


You need to add to it the mp3 codec as explained here.


Audacity deals with your mp3 by turning it into an Audacity Project (.aup) file for editing, useless on the Sansa, and .aup is what you get when you edit and Save Project, but it’s just a matter of terminology. Instead, you’ll want to highlight each chapter and  Export Selection as mp3 (again with a constant bitrate on the mp3 settings page you’ll see).

Try re-tagging first–maybe that will miraculously solve the problem. But if not, chopping it into smaller mp3s should definitely do the job.

I’d give a +1 on Audacity. I used that in he past and never had any problems with it.