Using SanDisk Clip for Books on CD

I check out library books on CD, create a named folder on both the Clip & my comp, use Audiograbber to upload them to the folder in my comp, and then drag & drop the book folder into the Clip (overwriting the Clip’s folder of the same name) & return the original books to the library. Generally I delete the bookfile I’ve just listened to first, and them upload another, so the Clip doesn’t get too full, but there are always several books stored in it. The person who gave me the Clip this Christmas is sick of my questions about it, so here goes:

1)What I need to be able to do is to access the book under a file name (in Music, or wherever) Click on the book to listen to it, and have the cds chain, so that the book is continuous rather than my having to click back on the player, look up the book, scan down the “albums” and click on the next saved cd. For example: Go to Music–>Artists–>At Wit’s End [one of the novels] and have all the saved files play in sequence. My worst-case scenario to date is with The Divine Comedy. I saved it like this in Audiograbber: Artist= Commedia. Album= Commedia 1 (etc). When I dragged the folder in & attempted to listen to the book in the Clip (taking the path of Music, Artist, Commedia, play all) to my dismay each track would play & then automatically repeat itself…so I found myself having to click the “forward” arrow twice on every single track to get to the next one! (Do I need to say that after about two hours of doing this…in the middle of Purgatorio…I began to feel I was in my own Purgatory & started listening to something else?)

  I figure there’s some correct way to save the book cds…and I just don’t have the “magic words” quite right…whether it’s the way I’m saving the books or the way I’m filing it on the Clip. Audiograbber asks for 3 things: Compilation disk (check the box or not), Artist, and Album. What to do? I’ve tried just about everything, but it’s gone from bad to worse.

Second question: I had been downloading books to my Clip at the rate of about 10min a cd file…and now that  I have a couple of gigs in there its either crashing or stopping. I got a firmware update, and am now in the process of removing all my saved folders–about 8 books–slowly,very s-l-o-w-ly from my Clip, back to my comp so I can format the clip. *sigh* will this “fix” it?

1.  You could join all the book’s computer files into a single file, using MP3Join or something similar.

2.  Are you dragging your book’s folder into the Clip’s Audiobook’s folder?  I thought that what I think you want is possible there (but maybe I’m not following fully). 

I also listen to a lot of audio books on my Sansa Clip, which I get from ripping CDs I borrow at the library. I usually use as the “album title” for each CD the title of the book plus the number of the CD. (So, for instance for the novel “Lolita”, I would have the album title “Lolita CD 1” for CD1, “Lolita CD 2” for CD 2, etc.) When listening to the audiobooks, the CDs show up in the correct order in the “Audio books” menu. To listen to CD 1, I go to “Lolita CD1”, then click the first track. The tracks will play until the end of CD1. To listen to CD 2, I have to go back into the “Audiobooks” menu and click “Lolita CD 2”, etc.

I agree that it would be even nicer if there was a good way to play the whole audiobook (all CDs) without having to “restart” each CD manually, but since each CD is about an hour long, and starting a new CD takes only seconds, this is not a big deal.

It would however be great if there was some kind of “global bookmark” option, i.e. a way to set a bookmark in a track, and a function that would let you jump to that bookmark directly from the “Audiobooks” menu. (As of now, if you stop listening and want to continue some time later, you have to remember the album(=CD number) and the track number where you left off.)

Message Edited by tglimm on 01-10-2009 08:09 PM

I used an audio joiner+converter to join the mp3 files and convert to an Ipod friendly format for my daughters Ipod. It worked well but takes a bit of time.

Try some of these out ( a lot of free ones ) http://www.google.com/search?q=mp3+audio+book+joiner&rls=com.microsoft:en-gb:IE-SearchBox&ie=UTF-8&oe=UTF-8&sourceid=ie7&rlz=1I7SUNA

did you try turning on chapter mode?  start your book then press the down button to get into the menu.  I listen to lots of audiobooks and it always just goes to the next cd.  I think chapter mode if off by default.

I’m pretty sure Foobar’s masstagging function (or try other dedicated taggers) will let you set the multiple CD’s up as one big album with the track numbers from the later CD’s translated up so they all stay in the right order.

Yes, you’re doing about what I’m doing right now…with a bit of difference in naming the disks. My mysterious experience with the Commedia cds recycling actual tracks was why I wrote in. I notice lots of responses are arriving! Thanks for your suggestion.

I’m feeling optimistic about this reply! Will try your solution & let you know if I can now check the big Green Arrow!! :smiley: