AudioBook Files Question

AudioBook Question for all you experienced Clip users:

I converted Cd audiobooks using ITunes to MP3. Using the internet it got the CD track information etc. The first CD was given the album name Magyk - (Disc 01), the 2nd CD Magyk - (Disc 02) etc. for 10 dics. Each track being given the following type info 1-01 001 Intro.MP3, 1-02 01A Something in the Snow.MP3 etc., the 2nd disc would say 2-01, 2-02 etc. I then copied the Magyk Book folders #1-10 into my new Sansa Clip inside Audiobooks using “Files & Folders copy to command”. The genre given by Itunes is “Books & Spoken” Anyway, when I go into Audiobooks open up the first folder it plays through its 19 tracks, then stops. It does not go to the second folder and start playing. I have to manually open up the next folder to continue listening to the book. When that folder finishes I have to open folder 3 etc.
But if I put the entire Magyk Book (10 folders inside) into music folder, I can go into Albums and hilite play all and it will go through each folder in order and continue to play. Audiobooks folder does not have the PLAY ALL option, is this because they expect to find all tracks for the book inside just one folder???

My question is this, when I convert my next CDs to MP3 should I change the album tag to read only “NAME OF BOOK” for all of its CDs, (no Disc 01, Disc 02 etc.) thereby creating one folder only. It seems that all the books I have converted already insist on naming each Disc with its own # after the Book Name.  Each track has its own ID such as 01.1, 01.2, then 02.1, 02.2 etc for each CD. I am assuming that it will continue to play the tracks numerically though the entire book, since there is only one folder. But the tracks are 3-4 minutes each so resume play should work well. ITunes has an easy way to change Track info before converting, so this is not a problem to do.

To sum up this long post, does a book under Audiobook folder have to be in just ONE folder, each track listed numerically in the correct order from start to finish in order to play continuously though the book?  I don’t want to convert anymore CDs as separate discs if this is how audiobooks works, I will do above instead.  By the way, the separate discs work fine on other flashdrive mp3 players I have, but they only have a MUSIC folder so they work the same as the clip under albums in Music Folder, I did not understand the Audiobook folder concept was different.

Am I correct in my assumptions?  Thanks so much…

Aliza

@Aliza:

I use my Clip almost exclusively for audiobooks . . it’s great. I get most of my books from CD loaned from the local library and rip them to .MP3 files.

Occasionally I download books using P2P protocol and bit-torrent.  I don’t use ITunes.  What I learned ripping and formatting audiobooks for the CLIP:

  • Put the files (or rip them into) a file system AUTHOR -> BOOK -> DISK (or Chapter) -> files.

  • I always “retag” the files with ID3v2 tags. (I usually delete all the existing tags before I “retag”.)  The CLIP uses “tags” to sort the order of play.

  • Very important to use “audiobook” for the genre.  It’s not on the pick list for ID3V2 tags, so just type it in.  I also put “audiobook” in the “comments” section, just for good-measure.  This tag gives you the “bookmark” function on the CLIP.

  • Tag the files thinking as you would a music album where ARTIST = Author; ALBUM = Book, TITLE = File Name, TRACK NUMBER = Track Number.

By the way, the file name is important initally, because the order in which the files are listed is the order the tag for “Track Number” will be applied.  So be sure the files are in the proper order when you retag them.  Sometimes you’ll get a sort order of 1, 10, 11 , , , 19, 2, 20 . .  if you get this then manually pad the single diget file names with zeros, ie; 01, 02, 03 . . . 10, 11, 12 etc.  You’ll get a much better sort.  Pad the DISK/CHAPTER number too, if more than nine. There’s software available to “bulk” retag files, find it and use it . . . much easier !  It will auto-increment the file’s TRACK NUMBER for you.

  • Use the MSC mode to connect to your computer (my preference) and load the completed book into the AUDIOBOOK folder. Grab it at the BOOK level with DISC/CHAPTER under it.

  • If you’ve done the retagging right it should play fine . . . one right after another.  All you need to do on the CLIP is go to MUSIC -> AUDIOBOOK and select your book. It should be listed.  In the CLIP display it’ll show you; Author . . Book Title . . Disc/Chapter . . File

  • The "bookmark"is a nice feature.  If you pause the book, or turn off the CLIP, it will remember where you were and start back up from there.

WHAT I DO:  My computer runs Linux/Ubuntu . . I rip audiobook CD’s using a software program called “ABCDE” . . I set the “-1” option and I end up with a single file for the entire CD, labeled Disc01, Disc02, etc. I save each file in a “book” folder under an “author” folder. ( AUTHOR -> BOOK ) and I have as many files as were Discs in the book.  Once I get them all ripped I delete all the “tag-information” and retag all the files with ID3v2 information compatible with the CLIP as I described above.  If I download a bit-torrent book, I sometimes get a book consisting of 200 files.  I look at the file structure and try to figure out how the files might be allocated on a CD/Disc structure.  Then I “join” multiple files into a single file that I think represents the CD using the linux “cat” command.  This then gives me a set of files that represents the original CD  . . . I delete existing tags and retag with ID3v2.

Hope this helps . . . you’ll  really enjoy audiobooks on the CLIP once you get the “hang-of-it”.