Unable to connect to media drive using Android 6 (Marshmallow) - Critical bug

Firstly I must complain that I opened a support ticket for this issue and was told that it was being handled by the technical staff. This was over a week ago and still my problem hasn’t been solved…

I own a 32GB drive which I use with a Nexus 5 phone and a Nexus 9 tablet. I upgraded the tablet to the Android 6 and sadly discovered that the Media drive client refuses to connect. It shows the drive but hangs once you press connect. I tried this on a colleagues Nexus 6 phone also running Marshmallow with the same results. Because of this I have refrained from updating the OS on my Nexus phone.

When is this problem going to be fixed?

marshmallow is fairly new and has not yet been rolled out to all devices. My guess is that an update will need to be pushed for full compatibility. these thing sometimes occur when a new version of an OS is released. Since you are already in contact with sandisk support I would recommend talking to them about a released date for a fix and try to keep in mind sometimes these type of things can take some time. 

I finally got a response from retail support that they couldn’t reproduce the bug. I sent them another email with full details of the problem and at last got a response that had been able to reproduce the problem and were working on a software update. As a professional software engineer I am not impressed by the time it took to admit there was a problem with the latest operating system but better late than never Lets hope they are quick to issue a fix.

It is working on Marshmallow. You have to connect to the drive’s network, wait about 5 seconds for a heads up notification saying there is no internet conenction, tap that, check dont ask again for this network, and then tap yes. Then you can just open the Sandisk Connect application as you would and it sees the files.

Yeah - I noticed this when the upgrade was issued on Saturday and wrote to Sandisk support complaining that this is still not acceptable (although it does mean the drive is useable again).  The original support tag is still open and hopefully they will issue a software fix soon.

For the  record I have two Android 6 devices and they behave differently. On one (a Nexus 5 phone) behaves perfectly. For the second a Nexus 9 tablet I connect using the technique you describe (although you don’t actually have to wait for the warning to connect).

I also have this issue. 2013 Nexus 7 with Android 6.0 Marshmallow.Sandisk we need your help with this. It works fine with my Samsung S5 operating on Lollipop. This is obviously a Marshmallow (6.0) compatability problem. My 64gb WMD and the 5 Sandisk SDHC cards with video on them are useless with this problem. That was the only reason I spent $200+ on all of this Sandisk merchandise. Please help your consumers.

I was helped by Jay S of Sandisk with a solution that I will copy and paste. It worked for me. Happy happy, joy joy!

  1. Close the SanDisk Wireless Drive App and clear it from recent apps list.
  2. Go to Wi-Fi settings on your Android device.
  3. Long press the name of your SanDisk Wireless Drive and select “Forget network”. Launch the SanDisk Wireless Drive App and connect to the Wireless Drive as usual.

this hapend me at motorola nexus6 fix this asap ok? tanks

Did you try the method that I listed above? If you did, and it not work, I would be surprised.

i do this and is work but i must do this evry time and is not  good