Unable to change contents of a document on a Secure Aceess protected Cruzer flash

I have a document on my flash drive, in the SecureAccess v2.0 folder.  I have tried numerous times to make changes in the document and even get the windows asking if I want to save changes, and I have made sure that it has the Flash drive selected and then it asks if I want the original replaced on the flash and I click to replace, but when I go back to the document it has not been modified. I tried removing the doc from the vault and placed it on the desktop and modified it and then dragged it back into the vault, but then there are only things called “previews” and metadata, etc-the actual doc isn’t there.

Can anybody help me. By the way I am using a Macbook Pro with the newest OS-Mavericks and have an older Cruzer  flash drive with Secure Access v2.0.


:smiley:   Hi Hmunster2,

Dear member of SanDisk Community, welcome.

Friend, remember that, there are two softwares, one for Windows and one for Mac.

Use with a Mac requires other software download.

System Requirements SanDiskSecureAccess:

- Microsoft Windows® 8, Microsoft Windows® 7, Windows Vista®, Windows XP.

=>  Mac OS® X 10.5+ (Intel Based Mac only).

=>  Not Mavericks 10.9.4

And SanDisk SecureAccess Software you must install in the UFD.

The latest version of SanDiskSecureAccessV2, you can download (free) from here:



Friend, see if it helps: http://forums.sandisk.com/t5/All-SanDisk-USB-Flash-Drives/Cruzer-Force-USB-Flash-drive/m-p/331213#M9550

Luck, and then you tell us, what happened, please.

Regards, Alfred.                                                             (Google translated)

Alfred, thanks. I have Mavericks 10.9.4-so that this mean it is not compatible with the secure access program?

:smiley:   Hi Hmunster2,

Yes, sorry, see link: http://forums.sandisk.com/t5/SanDisk-SecureAccess-2-0/SecureAccess-Mac-Mavericks-10-9-4-crashes-immediately/td-p/329977

Regards, Alfred.