Ultra II not working externally using USB to SATA


The internal SATA cable in my MacBook Pro gave out. I wanted to pull some data off my 480 GB Ultra II, so I removed the drive and hooked it up using a USB to SATA adapter. Unfortunately, the drive is not recognized at all. I tried it on my MBP as well as on an older laptop running Linux.

The adapter works using regular spinning 2.5" HDDs, so I know it’s not faulty.

Could this be a power issue (I noticed the SSD says 1.6 amperes on the label)? Or does it seem like it could have failed along with the cable?

I would be grateful for any suggestions!

I have ordered and tried a SATA to USB with a Y connector on the USB end. It doesn’t work either.

Should I just write off the drive or is there any chance of it working internally when I get the cable replaced?

sounds like the drive may be bad as well. depending on what went wrong with the cable it may have killed the drive as well. Contact sandisk support. If it is within warranty sandisk will probably replace it. 

It’s not even a year old. I’ll probably try it internally once the SATA cable gets replaced, although it does seem like a write off ???

Well, I got the computer back, installed the SSD inside and it started booting normally. I have no clue why it refused to work via USB, but I guess all is well that ends well in this case.