Truecrypt Fozen in 40% progress and I can not format my sandisk SSD

Hello everyone, first of all I apologize for my lacking English.

I have an SSD Extreme Pro 480GB which I was using perfectly until yesterday when I started encryption with TrueCrypt 7.2, as I had done other times on other HDDs and SSDs.

To my bad luck, truecrypt froze in 40% of progress, and after that the problems started.

I can not format in any way, every formatting attempt gives error and does not proceed.

If I try to install windows 7, it ends up crashing and does not install.

If I start windows from OTHERS, with sandisk embedded in the motherboard’s sata, the system hangs and does not start (only the “STARTING WINDOWS” screen is left) and does not leave it.

The SSD is perfectly recognized in the BIOS and sometimes in the windows disk manager (when this utility does not crash with ssd connected), but it shows as “unallocated space” and any attempt to create partition or format is useless because some message appears error message.

I have already tried to access it through a USB dock, the errors continue.

I’ve tried the sandisk disk utility, nor can it solve the problem.

I have tried several programs to format and create partitions, none works.

Something “written” truecrypt left on disk and that is causing all these problems.

Does anyone have any idea how to solve it? I’m hopeless now.

Thanks everyone!