Transfer problems Iphone 6 10.3.1

Firtly I have had issues transfering photos, some will transfer and some will appear ar a red file icon and then not open.
Secondly I transfered some videos and parts of the video will be broken, not play correctly possible currupted.
Finally if there are no solutions to these problems the issue may be the expensive piece of harware and if so how would i avail the warrenty as Philippines is not listed on the support page?

Thank you

I think this is a recurring problem due to some conflict of Safari browser and Sandisk

Read this:

@robertdane101 no the link from the apple forum is a different issue. that is regarding the playback of DRM protected videos from iTunes. Apple disabled DRM decryption in safari which prevents the playback of DRM iTunes content from third party devices. 

@shaz20 I would suggest backing up and data and formatting the iXPand using a computer. use the exFAT file system. Next I would transfer some known good data using the computer and make sure that data is transferring correctly. If so it would indicate the drive itself is working correctly. If that is the case then we can do a few tests on the iOS side. Do you have iCloud photo library turned on? If so transfer failures can occur if there are issues downloading the file from iCloud. check in the iOS settings > photos and camera and see if icloud photo library is tuned on. If it is try turning it off and then allow several mins for it to desync. Once it is fully desyned check the photos app and see how many pictures are stored locally on the iOS device. then try to transfer these files and see if that works correctly. 

@drlucky The icloud feature is turned off. I will try the other sugestions, specifically transfering good files from a computer, thank you for that sugestion that will really help identify in part if the unit is damaged. 

Thank you

Hi, I was having the same issues as the OP with videos no longer working after updating to 10.3.1. I reformatted my iXPand using my computer and know it is no longer recognized by my device (iPad mini.)

A follow-up. I reinstalled the iExpand App and all seems back to normal.

Same problem, copied one or two videos from iPhone all transfers from iPhone to iXpand drive fail! The app crashes every time, tried restart, tried deleting app. Nothing works.

If your researching this drive. DO NOT PURCHASE. This is a HUGE problem. This drive costs way too much money to stop working after 2 videos.


I have the same problem. I got Iphone 6 version 10.3.1 and sandisk 128GB. Everytime i make copies of my photos/videos or even back up the ixpand drive app version 4.4.0 would crash. It’s very annoying for an expensive flash drive! Is there a fix on this?