The 2.16 firmware upgrade fixed a restart problem in my 8gb Clip+

I had purchased the Sansa Sandisk Clip+ 8gb from Amazon over the summer due to the great reviews it had, it’s price point, and the fact it would play FLAC audio.  I received it and loved it, however after about two months in it started restarting itself constantly.  If I plugged it in to the computer, I could get a connection to the “drive” on the device, though it would still try and restart.   I could, however, access the drive.

I hard-reset it (power button 10 seconds), deleted all the songs off it, and I could not fix the problem, and I was outside Amazon’s return policy of 30-days, I believe it is.

I’m somewhat tech-savvy and my intuition told me it was a firmware issue that I had somehow run in to.  I deleted the songs in case the sandisk was just having problems with some of the files it was reading(I was playing mp3’s and flac audio files, for one, and flac I had converted myself), but a clean wipe and then a hard reset would not fix the problem, and the firmware available online was the same one as on the device.

I held on to the device because I felt that if the firmware was ever patched, it would fix the problem.

Luckily it did.  I just upgraded the firmware and then gave the device a hard reset and it’s playing just fine.  No restarting issue at all, it’s been about an hour.  I haven’t fully tested the device to determine if the problem will recreate itself, however, so far so good. 

I don’t know what exactly was wrong with my device, but I’m happy it works again.  Definitely recommend getting the upgrade if you’re running into issues.

“and the firmware available online was the same one as on the device.”

 The firmware in the player may have been corrupted. Downloading the 2.15 firmware again, and reloading it on the player might have solved the problem. The 2.16 firmware isn’t that much different than the 2.15 firmware.

It does have a way that it handles memory change.  It’s a moot point now, although I may have flashed it then, I downloaded the software to do it and would have flashed it  trying to solve the problem.

What could corrupt the firmware?

“What could corrupt the firmware?”

I have no idea what the cause is, however I do know that it might occasionally occur. I had a player of a different brand years ago, and every few months the firmware in it would become corrupted. Reloading the firmware version that the player had in it solved the problem every time.

 If the firmware update fixed it, but then it developed again, something in the firmware changes over time, because it can’t fix a physical defect.  That would indicate something with memory, I’m assuming.  My device is starting to exhibit some shutdowns after using it for a few hours, and I think a hardware problem (physical use over time) could possibly send the memory out of wack as it tried to reference some piece of the hardware that was incomplete.  However, the changes in the patch have kind of stabilized it out.  I could just test it again with 2.15 if I can find the patch and repatch the thing and that would definitely provide the answer.

Interesting food for thought.  xD

@kbinghii wrote:

I could just test it again with 2.15 if I can find the patch and repatch the thing and that would definitely provide the answer.

 

I really don’t see the need to rollback to 01.02.15 to do the test.  Any firmware update includes everything that previous firmware versions have.   The 01.02.15 version was a stable one and had been released over a year ago.  If something in that firmware caused frequent shutdowns, I’m sure it would have been fixed long before now. 

I suspect that your device is simply defective and it’s covered, if purchased new, under Sandisk’s warranty.  You have one year in the U.S., two in Europe, to contact Tech Support for a warranty replacement.

One test you can do is to play music only from card memory and see if that makes a difference. Are you sure the tags on your songs are okay(ID3 V2.3 ISO 8859-1 is what the player needs).