SSDP128G slow write speeds

Hi All

I have had the 128G for about a year now.  Write speeds are very slow however.

It takes forever to install a game in steam or any other windows application for that matter.  Read speeds are fine (i.e windows 7 ultimate loads in less than 20 seconds from boot)

AHCI is enabled in my motherboard (asus) bios.

SSD is connected to a sata 6 port on the motherboard.

Indexing is disabled on the drive.

The SSD has been like this since I bought it (i.e it has not got gradually worse)

ssd1

ssd2

Thanks

ssd3

try secure erasing the SSD. That should fix any performance issue related to the flash. If you see the same speeds after secure erase then I would test in another machine and if the results are similar submit an RMA request to sandisk support. 

I was having the same problems with SDSSDP128G slow write speeds.  The machine would often hang for seconds at a time.

Runing “atop” it would say the drive is 100% busy with only a few dozen write operations queued.

I’ve been running “fstrim” regularly to TRIM unused blocks, but it hasn’t helped as far as I can tell.

I followed the Secure Erase instructions and now speeds are back to normal (and I’ve lost some SSD life as a consequence).

I’m a Linux user and the instructions that worked for me are here: 

https://skrilnetz.net/the-truth-about-how-to-securely-erase-a-solid-state-drive-ssd/

In particular, to get the drive to be “not frozen”, I had to do the shown “echo -n mem” trick to drop into sleep and then wake up again.

(See the summary, below.)  Then the other two commands that set the password and did a security erase worked no problem.

SInce this was my root drive, I copied all the data off then booted Ubuntu Linux off a USB key and used that to erase my “sda” drive,

then I re-partitioned the drive and copied all the data back, set the GRUB bootloaders, and rebooted.  No more hanging!  Summary:

# echo -n mem \> /sys/power/state
# hdparm --user-master u --security-set-pass PASS /dev/sdx
# hdparm --user-master u --security-erase PASS /dev/sdx