SSD Plus not recognized on SATA 6gb/s port

I recently bought a 240gb SSD Plus to complement my Samsung 840 Evo. I run Windows 7 64bit on the Samsung and wanted to run all my games and programs off of the Sandisk. The problem is that I have two SATA 6gb/s ports on my motherboard (Asus P8Z77-V LK) and four of the SATA 2 ports. I cannot get the motherboard to see the Sandisk drive when connected to the SATA 3 ports. It will work just fine on the SATA 2 however. I know the SATA 3 ports work because the Samsung will show up fine on both. I have tried different cables (all rated for SATA 3) and updated the BIOS on my motherboard. According to Sandisk SSD Dashboard software my SSD has the latest firmware.

What am I missing to get the SATA 6gb/s to work with this drive?


this seems to be a strange issue with the drive, so you can try to contact the support of Sandisk to see if they have a possible solution for this case or maybe they have some more information on what are you missing in the installation of the drive. 

you can contact them directly through this link