Slow to wake from sleep


I recently bought a sandisk extreme ii 480gb. Did a fresh install of windows 7 home premium. Enabled ahci before that in bios. I’m using a Samsung np350u2b. I have 8gb ram. 

My problem is that the SSD takes about 20-30 seconds to wake up from sleep state. That’s almost the same time as booting up. I hae disabled hibernate and hybrid sleep modes. I have increased the pagefile to 12000+mb. Can someone help me with this issue? I used to be able to wake up in 3 secs with a regular HD using hybrid sleep. 


I want to add that the hdd/ssd light stays on for the entire 20-30 secs and only after it starts blinking, then I can work as per normal. 

Try disabling HIPM. The link below shows instruction for enabling and disabling

I do not have HIPM option. Does this mean that I do not have it enabled? If so, should I enable it?

yes be default the option is hidden. you will ahve to enable it. instruction are in the link i provided earlier. 

I enabled it and then set it to active (to disable HIPM) but there’s still a delayed wake. I mean, I can move my cursor and sometimes scroll thru tabs on chrome. But I cannot load any programs while the hard disk light is on. Then after 20 or so seconds, the windows chime sounds and the hard disk lights blink and then it goes back to normal.

One more clue is, the color management settings somehow is set to default everytime I boot up or wake from sleep and then applies itself after the windows chimes sounds. The color management is configured by intel because I couldn’t set it to apply everytime by windows. This is strange because I could always apply it automatically before on my regular HD. 

Any advice? 

what SATA driver are you using? I would check to see if the motherboard has any updated drivers. 

I’ve checked all versions and I believe mine is the latest one. Is there a way to check how much is stored on ram during sleep? 

Interesting - I’m having similar problems, but on a Macbook Pro (MacBookPro8,2, OS X 10.9.1). I’m on the latest firmware (R1311).

When I wake from sleep, I can move the mouse, but that’s about it. I have a password enabled, and OS X blocks me from putting it in for a good 10 seconds. I’m not seeing anything in the system logs, but I didn’t have this problem with my old SSD.

When I’m next home I’m going to disable my screensaver password and see if I can pick up on anything during the freeze.

I’m having this same issue on a MacBook Pro 8,2 (Early 2011. OSX 10.9.1).  I recently switched from the OWC Extreme Pro 240 GB to the SanDisk Extreme II 480GB.  The OWC never experienced this slow to wake issue, and it still doesn’t (moved it to my older macbook pro when I replaced it).  I’ve contacted SanDisk support and they have refused to try and troubleshoot the issue but instead keep pointing me to articles that aren’t related to the actual problem.  I’m curious if any one here has found a solution yet? 

What stinks is that after the 20-30 second delay when waking from sleep, it works great.  I need the extra disk space and I like the speed of the drive all other times, just frustrated that it takes so long to wake from sleep.  The OWC was lightning fast.


I was curious if perhaps TRIM enabler was causing problems, but it turns out it was disabled. I just turned it back on, so we’ll see if anything changes.

Of course, this wouldn’t explain anything under Windows where TRIM is automatically supported.


I have just purchased a 240GiB Sandisk Extreme II disk for a new Haswell i7, 8GB RAM laptop. Machine is terrifically fast, great transfer scores in disk benchmarks, BUT I have exactly the same problem reported here:

  • Slow to come out of sleep, every time.

  • Disk light stays on during this period, and windows 8 (yuk) freezes during this period, which could be as long as 10 seconds.

The interesting thing is, that coming out of hibernate is faster than out of sleep!

Looking forward to any ideas on how to resolve this…



Just raised a support case, so hopefully will get some resolution soon.


I have heard back from support: they suggested disabling HIPM, which I have and it has made no difference. Anyone else managed to resolve this issue?


I’m still having this problem on OS X. I just Bootcamp’ed my laptop and installed Windows 8 on it. So far, I’ve been unable to replicate the problem there. However, I also don’t even have the option to disable HIPM or anything like it under the Hard Disk power settings. I’m guessing that’s due to the BIOS compatibility layer that Macs use, but if anyone knows how to turn on HIPM anyways then I can see if that recreates the problem.

I’m not sure if OS X supports HIPM / DIPM at all - there doesn’t seem to be a definitive answer online.

Same problem here :confused:

I’m using a Macbook Pro 8,1 and had a ADATA SSD 120GB at 6GB/s. Switched to Sandisk Extreme II 480GB at 6GB/s. Previous to the switch I had no problems whatsoever besides the lack of space, hence the change. Now, with a clean install of MAC OS X Mavericks, the behavior is as described by deviantintegral in this very post - just mouse hovering for a while…

By the looks of it, I think that a firmware update would come handy.

Any news on that?

I’m having a similar problem with a 480 GB SanDisk EX II on a Z87 desktop mother board, Windows 8 PC.

Just got the EX II, so just have it connected to the PC, not an OS drive. It works fine in all situations except waking from S3 Sleep.

Upon waking from Sleep, the EX II is not seen in Windows Explorer, Disk Management, etc. The EX II does not appear after a minute or so as some other users have reported, but I’m not using it as an OS drive yet. A restart of the PC will cause the EX II to function normally again. It works fine from a cold boot. It won’t wake spontaneously after coming out of Sleep.

I’m using the latest Intel IRST driver, 12.9, and the EX II is connected to an Intel SATA III port. I tried adding the HIPM and DIPM settings in the power options, with no affect after trying various options. I have Link power management disabled.

I have three other SSDs in this PC, and none of them have this issue. I realize that these slightly older SSDs may not have the same options/features enabled that the EX II does, but I’m surprised this issue was never seen in testing. I tried going into Sleep, and waking the PC within one minute, and the EX II is not seen/active in Windows.

I heard back from sandisk on the 5th Feb:

"We have been looking into this issue which you are experiencing.
SanDisk has been made aware of this issue and we are currently working on a solution for this. At this time however, we don’t have a fix yet. "

Its been 3 weeks and I’ve no more news. I am also suprised that for me this is such an easy issue to reproduce, so how come sandisk and frankly more people (eg ssd reviewers) didn’t spot and raise this issue sooner?


PS: Edited to ask: has anyone else raised a support ticket with Sandisk? I’m not sure they read these forums.

Peter_S, no I didn’t create a support ticket with SanDisk about this, just noticed it yesterday. Until I’m sure something is really wrong with a product, I don’t report issues that may not truly exist.

Regarding more news, keep in mind issues like this, which can be related to the SSD controller’s firmware or the SSD controller itself, are very complex things. The environment the SSD is used in (hardware and software) are variables that add to the complexity. The SanDisk EX II is not the only SSD that uses the Marvell 9187 controller, and this controller has been used for a while now. If those SSDs do not have this issue, that narrows down the problem, but knowing that takes time.

It is rare that a fix is one small thing that will not affect other things about the controllers operation. Even if a fix is simple, verifying the fix takes time, not to mention creating and testing the fix, such as a firmware update. It is irresponsible for a manufacture to quickly release a fix for a problem without testing it thoroughly, which takes time.

Why didn’t reviewers find this problem? Either they never tested waking from Sleep, or the environment they used for testing does not cause the problem. I suppose they would consider testing that rather mundane.

I emailed SanDisk support, linking to this thread. They responded saying that it’s a known OS X issue, but I’m not totally sure of that as many of the links they sent are for years-old unrelated issues. I might try calling to see if that gives better results, or perhaps Apple just to see if perhaps it is a known issue and the support tech just didn’t have the full background.

And, this wouldn’t explain any of the trouble people are having on Windows. Here’s the response I got:

Thanks for emailing SanDisk Technical Support. It is our goal to make sure you have all the resources you need to get the most from your product.
I apologize for the inconvenience this may have caused. I would like to inform you that it is a known issue on MAC OS X 10.9.1 OS. There are a lot of customer’s facing the same issue on MAC OS X 10.9.1 which is also posted on multiple MAC forums. Please refer to the below mentioned link:
This issue is not specifically related to SanDisk SSD as there are multiple users on the Apple forums who are facing issues with HDD and SSD drives as well. Apple is already aware about this issue with the operating system. I would request you to contact Apple to find if they are planning to bring a new update for the OS.