SDDR-199-E20 stopped reading 4GB/8GB Extreme III


Purchased 16 May 2010 via Amazon

Can’t supply serial number as it’s worn off.

Using the original cable as supplied with the ImageMate

I’m using a Lenovo G770 laptop running Windows Home Premium 64bit

I’ve been using the ImageMate daily with my SanDisk Extreme III 4GB and 8GB SD cards for two years.

This week it suddenly won’t recognise either card - which are used in my cameras, and both seem to be fine.

The cameras are writing to them OK and I can read the cards on the the laptop’s internal reader OK (but the ImageMate is much faster).

That is, the laptop does not recognise a removable device as having been attached.

If I put either an old generic 32MB (that’s right) or SanDisk Extreme III 1GB, SD cards, they are recognised and I can read/write them, but not every time.

I’ve tried reformatting the 4GB & 8GB cards - no difference, still can’t see them.

I’ve tried removing the USB Mass Storage device in device manager and let it reinstall on next boot - no difference

When a card is inserted that is recognised, then the blue light on the reader flashes. When a card is inserted that is not recognised, the blue light comes on but does not flash.

What else can I try or is the reader just good only for the trash now?

The 2-year warranty on this device is now very nearly up - should I simply expect a SanDisk device to break the moment it’s warranty expires? 

Sounds like you have done just about all that can be done. It is likely dieing. I would contact sandisk and check on warranty.