SD Extreme Portable SSD Bricked on Day 1?

Hi all, really hoping someone can help me out here. Failing that, even confirm my worries that the device is useless.

Brand new SD Extreme Portable SSD 1TB, worked briefly for a few big files, then stopped allowing files to be transfered (kept disconnecting itself when trying to transfer more larger files).

After reboot, drive is read-only and Windows prompted a drive repair, did so, after which the disk drive was unreadable as an allocated volume (F: / G: / etc.). i.e. has no assigned drive letter and therefore, Check Disk (chkdsk) cannot be performed.

Disk manager shows the disk drive as MBR Basic, Unallocated, when prompted to initialise disk, receive the warning that: Virtual Disk Manager: Incorrect Function. Cannot be initialized as MBR or GPT. Simple volume assignment/partitioning is completely greyed out, only option is to retry initialisation, which obviously fails.

Diskpart acknowledges the disk, it can be selected, it can be cleaned, but it cannot force initialization (conversion); create partition; or assign volume. Removing attributes of readonly displays as a success, however the disk drive promptly disconnects itself and needs to be reconnected to appear on the rescan list again. Makes me think there is a built in ATA lock or similar by SanDisk preventing certain functions.

SanDisk Dashboard Utility recognises the device via USB, displays no volume, only unallocated disk space. Interestingly, shows disk as “_ healthy " and " normal ," quite farcical. Perhaps the more useful information It displays is " Security: ATA, Enabled, Locked _” - could this be why Diskpart or Disk Manager can’t do anything?

Following the SD Dashboard avenues of TRIM/S.M.A.R.T. scan/Erase Data/Update Firmware etc., all return “_ normal _” status.

I next tried both AOMEI and EaseUS Partitioning Tools, and both return the issue when trying to initialise or create partitions: 
Error, the operation cannot be completed because it is prevented by another process - or something to that effect. 

Is there anyone who has gone through a similar process? Is the drive defunct and beyond rescue? Any thoughts at all? Please? 

Thanks in advance.

  
EDIT: Also worth mentioning that EaseUS/AOMEI partion recovery doesn’t detect anything and when performing a ‘surface scan’ about 10/10,000 sectors are showing as ‘bad clusters/sectors’ - just incase it’s related, but I still believe it is some sort of hardware lock that is overiding everything. 

Use gparted

How to create partition via gParted