Saved Files Disappeared from my Sandisk Cruzer Slice 32GB when Previously There

Hi There

I’m hoping someone will be able to help me…

I have transferred all the photos of my 6 month old son onto my newish (Oct 2012) 32GB Cruzer Slice as I needed to have access to them both on my laptop and PC. I saved the photos into subfolders by month and called the overall folder by my son’s name Aaron. I did not use secure access, just used it as a removable drive.

I have continued to save more photos onto the data stick, not using the secure access, but simply using the stick as a normal drive. Now I know you’re going to tell me I’m stupid and that I should have backed these pictures up, but please believe me I am gutted that I did not do this and now its too late.

A couple of days ago, a sub-folder called Nov 2012 no longer showed on the drive when I had been copying more photos over even though it had been there previously. I thought I must have accidentally deleted it or moved it (although that is not something I would normally do). Checked the bin and no Nov 2012 folder was there, so assumed it was my mistake and tried to recover Nov 2012 pictures from my camera and phone SD card, some of which I got back. When I tried to create a new folder for Nov 2012 to put the recovered pictures into, it told me that Nov 2012 already existed and did I want to merge the new folder I was creating into it. But the original Nov 2012 was not showing as a sub-folder.

Then yesterday whilst using the USB data stick, my folder named after Aaron disappeared with all the subfolders containing every picture I have ever taken of my son. I don’t know where it went, I know I didn’t delete or remove it. I wondered whether it was still there and tried creating a new folder called Aaron, and again it told me this folder already existed and asked if I wanted to merge the 2 together.

When looking at the properties of the data stick, I note that it says 1.29GB has been used (of the 32 GB), but this can not be accounted for by the system files on there (SanDiskSecureAccess etc.) which amount to about 50MB. This suggests to me that my files are still on there but for some reason I can not see them to access them.

Since this has happened I have not removed the data stick from the laptop and have kept the laptop on for 2 days in the hope that I can retrieve my lost files.

I would be extremely grateful if anyone could offer some advice or a remedy.

Thanks so much


What are you using to view the folders on the Slice?  Windows Explorer or some other app?  It sounds like some other app, maybe something for viewing pictures, that only shows the last x number of folders accessed.  The files are there but the app isn’t showing them.  It could be a setting that you can change, or not.  Use Windows Explorer and see what it shows.

BTW Using the Slice directly rather than feeding everything thru SecureAccess is a good move.

Hi Ed

Thanks for the reply, I was using Windows Explorer and have used this all along to both view and transfer files tto the data stick.

I just set my view to “large icons” to view the pictures within explorer.

My OS is Windows 7 64bit.

Any help that you can offer would be gratefully appreciated.



Ok.  Temporarily changed the view to Details.  Do the missing folders show up then?  How about if you click on the Name header?

Hi Ed

Have changed to details, still only shows the data stick ‘system files’. Only used the large icons for looking at the photos themselves, when organising them/their folders I used the list view.

I’m not sure what you mean by name header?

If you mean the data stick as it appears under computer in explorer, it still shows just the system files.

Doesnt seem to matter how I view the data stick in explorer, it only shows those system files, but still maintains that 1.29GB of space has been used.



I’m confused.  NONE of your pictures or picture folders are visible!!  I thought some were.

Ok, from a Command Prompt enter a CHKDSK command for the drive letter assigned to the flash drive.  For example:


where F: is the flashdrive’s drive letter.

Does that help?

Other things to try:

With the flash drive plugged in RIGHT click on the desktop’s Recycle Bin icon.  Does it show space allocated on the flash drive?

Does your laptop’s antivirus show any of the files or folders as having been quarantined?

Can you use Windows Safely Remove function to remove the flashdrive?  If so once removed shutdown the laptop, not restart, shutdown.  Let it rest, you too, then turn it back on and reboot it.  Once it settles down insert the flashdrive and see what it shows.

Hi Ed

Thanks for the response.

I only had 1 folder on the flashdrive called Aaron which contained 9 subfolders which had all the photos in, and it is Aaron which has disappeared, along with all the subfolders within it. There was nothing else on the drive other than the ‘system files’ which are:

Folder -         Club Application                              14.6 MB

Folder -         My Vaults                                           17.8 MB

Folder -         SanDiskSecureAccess                  8.95 MB

Application:  RunClubSanDisk                             108 KB

Application:  RunSanDiskSecureAccess_Win 29.2 MB

Well, I tried checkdisk (gosh its a long time since I used DOS!), anyway the disk seems fine and this is what it said:

The type of the file system is FAT32

The volume is in use by another process. (!!!)

Chkdsk might report errors where no corruption is present.

Volume Cruzer Slice, created…serial number…etc.

Windows has checked the files system and found no problems

31,250,016 KB total disk space

128 KB in 8 hidden files

832 KB in 49 folders

1,347,600 KB in 1,684 files

29,901,440 KB are available.

Tried right clicking recycle bin, I assume it was a right click, properties? Anyway if so, nothing is allocated to the flash drive, only drives mentioned are on the laptop.

No files are quarantined in AVG.

Have safely removed flashdrive and shutdown. Waited about 20 mins, then restarted. Flashdrive exactly as it was.

Still reporting (under flashdrive properties in explorer):

29.8GB Capacity

1.28GB Used Space

28.5GB Free Space

But the ‘system files’ total only 70.8MB, 87 files and 41 folders. This is very different to the 1684 files and 49 folders reported by Chkdsk.

Any suggestions?



PS Sorry about the delay in response, I’m on UK time and have to keep stopping to look after my baby, Aaron!


You appear to be running Windows XP, yes?

As for CHKDSK indicating the volume being in use by another process, did you have it displayed in Windows Explorer at the time?  If not maybe your AV was scanning it?

The CHKDSK shows  1,347,600 KB in 1,684 files which would indicate your files are there.

At your friendly Command Prompt do a DIR ?:  where ? is your Cruzer’s drive letter.  Does it show Aaron’s folder?

If not, again in the Command Prompt do a ATTRIB  ?:*.*  where ? is the Cruzer’s drive letter again.  Does it show Aaron’s folder?

BTW Congrats on Aaron. :slight_smile:

Hi Ed

Thanks for the congrats, obviously can’t send you a pic of him!

Actually I’m running Windows 7 64bit.

I could have had the flashdrive open in explorer when I did the chkdsk earlier, so I closed it down and made sure it wasnt being used anywhere else including my AV and ran it again just now, it still says that it is being used by another process.

No Aaron showing on the DIR command, just the system files as detailed in my previous post.

ATTRIB shows

G: \autorun.inf

G: \RunClubSanDisk.exe

G: \RunSanDiskSecureAccess_Win.exe

No joy!


Actually I’m running Windows 7 64bit.”

!! So am I, but your CHKDSK output looks different than mine.

Ok, at this point, I’m out of ideas.  :-(  Find a professional recovery service and have them recover your photos.  It may be expensive but I think Aaron is worth it.


One last idea, actually two. 

  1. Do an image backup of the drive.  Especially before sending it out but also before doing anything that writes to the drive.

I suggest RunTimes DriveImage XML.  It is free and I trust it.

  1. Once backed up try running a recovery app to see if it can see your files and possibly recover them.  There are dozens on the 'net that will scan your drive and may find your files but then charge you to recover them.  I’ve used TouchStone’s Undelete_Plus and photerec_win.exe from whom I don’t remember and Restoration from here .  Try one or more just to see if they see Aaron’s folder before doing anything else.

Hi Ed

Thanks so much for trying to help, I will do an image back up.

I also wondered whether Sandisk themselves may be able to help since the files seem to be there, but aren’t, if you see what I mean. Do you think its worth trying their techical dept?

Else yes I will try to recover, and hope that any recovery software finds the files, irrelevant of cost.

Thanks for all your time and suggestions Ed.

If anyone else out there has any suggestions, they will be gratefully received!!

Bye Ed


@manj wrote:

I also wondered whether Sandisk themselves may be able to help since the files seem to be there, but aren’t, if you see what I mean. _ Do you think its worth trying their techical dept? _


It can’t hurt. It is after all, what they get paid to do. :wink:


1.  All those apps I wrote about before are free and I have used them in the past.  They do work.

2.  When you run the Command Prompt are you running it with Admn rights or with Limited User rights?

Hi Ed

I think I’m using it with Admin rights since I am an ‘administrator’ on this laptop under Win 7, not sure if you mean something else. But as you know am happy to try anything…

Am running a restore currently with a freebie, PC Inspector Smart Recovery. Interestingly, it said that it could not conduct a fast recovery because the flashdrive was so badly damaged and is doing a detailed or something similar (can’t remember which word it used) recovery.

I will post and let you know how it all goes.



" it said that it could not conduct a fast recovery because the flashdrive was so badly damaged and is doing a detailed or something similar (can’t remember which word it used) recovery"

Marj that sounds so much like a scam. :cry:  If the drive was so badly damaged you would not have been able to see the SecureAccess files on it. Why didn’t you use one of the apps I suggested?? 

 I do hope things didn’t get worst.

Hi Ed

I agree that I dont think that the drive is damaged, but the software is free anyway so whether it did a detailed or quick scan didnt matter.

Anyway it did successfully retrieve the pics, so I have all of them back I think. It didnt retain my file structure however so I dont which month they were taken in.

The only files it didnt get back are videos I took of Aaron, but at least I got the pictures.

I did try Restoration, but it kept crashing, so tried to find an alternative.

Thanks for your help Ed, I’m a happy mummy again!



I did try Restoration, but it kept crashing

I believe I gave you several apps to try.

Anyway it did successfully retrieve the pics, so I have all of them back I think.”

Excellent, excellent news.  :smiley:

I’m a happy mummy again!”

You made my day. :heart:

I’m having exactly the same problem.  Did you ever find a resolution?

1 Like

My Micro SD card is 32GB and I wiped off everthing but I see 1.29gb used on a 29.8 GB SD card which now leaves 28 GB This is normal I looked into it and there’s no files in there at all just pre made folders as soon as you insert it into any portable device companies do that it’s never the full 32GB stored that you can use and there’s always system properties left which take up few gigs and you cannot access these files, I also thought I had few pics left in there but I manually looked into each folder from computer and also inserted into phone to see if there is any but none showed up.Upon making the USBs and HDD the tiny motherboard holds few important data to make it run which takes up few GBs.

So you registered to post to a thread that hasn’t been active for 4 1/2 yrs!!  Spammers have been known to do that, are you a spammer?