Sansa Fuze Power Indicator

I tried sending an e-mail to but got no reply.  I’ve also tried searching these boards for a problem similar, but I didn’t have any luck.  If there is a similar thread, please just point me there.

Here’s what I sent to Sandisk:


I recently (last week or two) purchased a Sansa Fuse (silver 8 GB).  After charging it and removing it from the charger, it immediately shows a 94% charge.  After a song or two, it’s down in the 80s.  I’ve used it and recharged it a few times now, with the same results.  Just today, I purposely let it charge down to 10 or 15% and then fully recharged it, with the same results.


When I say “fully recharged”, I mean that the blinking battery indicator stops blinking, indicating that it’s fully charged.  As soon as I remove the unit from cable, I can immediately see a sliver of not-fully-charged in the battery indicator.


I’m using Windows XP SP3, I generally charge the unit with a USB port (not a dedicated USB charger), and the firmware on the Fuze is V02.02.26A.  I haven’t tried using a microSD card.


I have another Fuze (silver 8GB) that doesn’t behave like this.



Thanks for your help!

you should be charging at least 3 hrs for a full charge. if you are still seeing the same issue and you have other fuzes without the issue it could be a defective battery. if this is the case i would return the fuze to your place of purchase since it is within 30 days.

Try doing a soft reset, hold the power switch in the ON position for 20 seconds.

If that doesn’t help, try formatting the player.

If that doesn’t help, call 1-866-sandisk.

I’ve already had to do a soft-reset for an unrelated problem where I shut it off while it was playing a movie and when I turned it back on, it thought the movie was a song with four tracks on the album – very strange.  When I switched to another mode, it became unresponsive and I had to do a soft reset.  (Also, I had this problem where, when listening to some songs on a particular album, if I changed the backlight time, it would freeze then shut down, but it turned back on OK, so no soft reset was necessary.  These units can be a bit flaky.)

I guess I’ll let it discharge and charge it one more time and if that doesn’t do it, I’ll get in touch with Sandisk.  I don’t really feel like going through the return hassle with Best Buy.

I suppose this problem is solved – either try again or I have a defective unit and have to return it.  No one else seems to have the same issue – should I label this solved? 

Thanks for your help!  And thanks to the other poster too!

This isn’t normal behavior so you must have a defective unit. Doubly so, since you say you have another unit that behaves completely different.

BestBuy usually doesn’t hassle it’s customers on returns. Maybe if you’re lucky enough to have more than one store in the area, you could return it to a different one.

Regardless, and whether it’s a hassle or not, I would return it to BB. You’ll get it resolved in 1 day rather than weeks if you go through SanDisk and have them replace it under the 1 year warranty. Not to say that is bad service by SanDisk. It just takes that long.

i’ve almost the same, but when i connecting the player, the player charge for 10 seconds, stops and appair full of charge.

i replaced it and the second is doing the same…


You’re actually running into a separate issue regarding the video hang-up- it’s a bug with the latest firmware.

Simply put, stop the video before shutting down the player.  You can resume the video playback at the same point later via the Resume from Current Position / Resume from Beginning function.  If the Sansa is shut down with a video file loaded, you’ll get that interesting screen with the thumbnail view.

The player can be reset using the soft reset (hold the power switch in the ON position for 15-20 seconds to reset).  It will perform a database refresh upon restart.


Sadly I’ve the same problem. It shows full charge while connected to PC and after Disconnection it show only a half. I’ve charged it for one night and still nothing :frowning: Seems this problem become more common :((

Yeah, I’ve seen that mentioned in other places, about video playback.  I just don’t turn it off anymore with video playing.

Regarding the battery, I ended up sending it back to Sandisk and got a replacement.  The new one has no battery indicator issue.  I really like this player!  (Now, if only rockbox were available for it…)


I had a similar problem on my fuze.  I solved the problem by purchasing a wall charger for the fuze and let it charge for a few hours with this instead of letting charge through a USB port attached to my computer.  After disconnecting the fuze and turning it back on, I had a solid green (100%) charge.