Sansa Express won't turn OFF

unlike most of the folks on this forum whose Sansa Express’s won’t turn on, mine has developed a problem today where it won’t turn off.  Actually it does appear to turn off, for just a moment, then turns back on.  It had been working great since I got it 3-4 weeks ago, then today it’s gone haywire.

I’ve done the following to tshoot this:

1)updated to latest firmware version

2)tried holding the select + volume up buttons for 30+ seconds

3)tried with and without a 2GB microSD card (Adata brand)

Is there anything else i should try before calling support?



Hello FaronF, Welcome to the Community!

Please contact Technical Support at:


7 days a week:
4:00 am. - 10:00 pm. (PST)
7:00 am - 1:00 am (EST)

OK, so the night i posted the msg above, i left my Express plugged into my laptop.

When i unplugged it the next morning, it turned off w/no issues, and i’ve turned it off/on several times since then.

The bad news is i don’t know what fixed it.

The good news is my Sansa is self-healing!  :slight_smile:

I had same problem.


I put a memory.

I don’t know why, but it works.