Sansa Clip won't work even when I try to reset it...

I don’t’ know what really happened I was listening to it and then the clip just turned off and I had recently charged it but I just shut off… I held down the power button and still nothing even when i held it down for a whole minute. I also tried to charge it but nothing will show up. 

The same thing happened to one of mine-------I called support----very helpful-----sent it back—waiting on replacement now—just got an email from them ----they are shipping it today------good folks to deal with----only problem I had was----they talk to fast—I’m old and slooooooow-----but all is well now—good luck—

Try pressing the Home button immediately after the power button. If this doesn’t work, try it with the Center button (just after or at the same time) as the power button.

Both have been reported as waking up an otherwise hibernating player. :wink:

FWI, I have owned a couple of these Clip+ devices for 2+ years and have had a few freeze ups and as well as “it won’t start” issues.  In every case, just leaving the device alone (whether plugged in to the USB or not) for 12- 24 hours solved the problem.  Last occurance(about 6 months ago), I had already arranged RMA, but it was “born again” after just sitting on the desk for a day,  and now continues to function w/o issue.  I continue to be amazed at the value these puppies offer.