Sansa clip screen cracked and need help turning repeat off

My screen is cracked and I can’t afford a new mp3. Unfortunately it was on repeat 1 song mode when it got cracked.  I just need a walkthrough to how to turn repeat off.  I can’t see my screen at all. I also would like to know how I could put it on playall mode instead of just one song.  I’ve tried to reset it but it doesn’t work. I’ll be away from my own computer for a few months so I’d rather not format it because I will loose my original songs that I have on it.  I also have an audio book on it so a walkthrough on how to access that will be helpful too.

hmmm  I’m not sure how helpful this will be:    Do you see anything at all on the screen?

My firmware version on the clip is :  01.01.30a

Starting point:    When i turn on my clip it automatically starts playing my last song and obeys the shuffle / repeat options.

Pressing the small menu button I will be positioned on Music

Music (headphones icon)   …  if i click down i get the following menu items:

FM Radio



Music     (back to music again)

if i click select on Music     I will get the following features:

Play All





My Top Rated





Music Options

Play All  (and back to play all)

If I am in play all and the song is playing:  each down arrow will give the following:

Back to music List

Add song to Golist

Rate Song

Shuffle   (off / on)

Repeat  (All, Off, Song) **

Music EQ

Clear Golist

Delete Song

Back to music list (and back to music list again)

if in this menu i click Right arrow on Repeat ** for each time i press right arrow  i will rotate the following 3 options




Lets start with the Clip off:    so:   If your clip is on…  turn it off…

If your clip is now off,  start by turning it on:

then click small menu button

then click select

then click select again to _ play all _ music

        wait a few seconds and the songs should start playing.   or if its on paused , un-pause it   Click up

To change the repeat feature:  while it is playing a song …

click select

click down 5 times

then to change repeat  click right    the options will be   All, off, song and start over with all, off , song  again.    this will start with whatever option is currently set.    

So if its set to     Repeat Song.     click Right once  to change it to Repeat All ,  click right again to change it to Repeat Off

Click Select = middle button on wheel

Hope this helps,   reply back if this did.   and I will look at the audio books next time :)  Or someone else might :slight_smile:

Thank you so much that helped alot. now i’ll at least be able to navigate through it until i’m able to buy a new one.


This was good advice. However, the audiobooks are even more important to me. Would you be so kind to guide how to get there either from the starting menu or from where I am on “play all”. I managed to get into the audiobooks-section by your guide here, but as I cant just switch tracks by pressing left och right I am stuck. How do I change between audiobooks-tracks once I have managed to get in there?


Thank you for the help!

My screen has been broken for ages and after getting it to work once, after changing the music I couldn’t get it going again.

Now I have music again, from a source with an amazing volume output.

Then it suddenly only repeated the same song. Not sure how that started. But now I can turn that off. Great!