Sansa Clip+ crashes

Hi there!

since a while I have a 8GB Sansa Clip+ - and I’ve always been very pleased and happy with it.

Yesterday I got new MP3-songs from a friend of mine (recorded music from his band - so nothing illegal). Listened to them on my notebook - everything’s fine.

So I copied them to a new (sub)folder on my clip, disconnected from the notebook, waited till database was updated and wanted to listen to the new music. The first time I tried, the Sansa logo came, then was nothing and after a while the settings menu appeared. So I tried another time, the screen starts to move from the music list to the play screen (the one with the music title and pause…) but the the clip got stuck . I can see now on the left half partly the list of this folder and on the right half partly the play screen. And that’s it - the clip is dead. I can press whatever I want but nothing happens. I can connect to the notebook, but it doesn’t realize the clip. The only thing I can do ist wait till the battery is empty, charge and then the player runs again. But only with all the old music (and some other new music I copied yesterday). As soon as I go to the new folder with the music of my friend I have the same chrash again.

So I deleted the folder. made a new folder somewhere else, and copied the songs to there - same effect

So I used the Sansa updater - newest firmware - same effect…

…but as I’ve said - on my notebook the music works perferctly. The only difference I’ve found (but I compared only with a few old songs) is that on the new ones the archiv bit is not set - but I can’t test that now as I have to wait till the battery is empty to get access to my clip again…

Update - reset funtion does work, makes it easier… on the clip the archive bit were set for some reason - but still i set it on the notebook and copied them new. No effect.

After the first error (where the logo appears and after a while the settings menu) i can see very short “updating database” - so I thought the problem might be there - deleted mtable.sys, disconnected, database was updated again - still the same s*** :frowning:

Anybody got an idea what is happening here?



The ID3 tags on these new songs are either missing or f’d up.

even if I found out by myself ;), you’re right - there were no ID Tags… and it’s running now…

Thank you!

kr, Luis